Hi,

just got the hint from Angelos, that ubuntuGIS unstable yesterday got
updated to GDAL 2.1.0 and GEOS 3.5.0, so a re-built of the packages in
qgis.org should solve my problems.

@Jürgen: Could you do that? 

Thanks, Otto

Am Fri, 15 Jul 2016 16:38:35 +0200
schrieb Otto Dassau <das...@gbd-consult.de>:

> Hi Carlos,
> 
> thanks for your suggestion, but this doesn't seem to help, probably
> because qgis packages depend on libgeos-c1 and libgdal1h
> see http://qgis.org/ubuntugis-ltr/lists/qgis2_trusty_main_amd64_Packages
> 
> and libgdal1h : Depends: libspatialite5 (>= 2.4.0) 
> and libspatialite5 : Depends: libgeos-c1v5
> 
> and this causes the dependency problem: libgeos-c1v5 breaks libgeos-c1 as
> the error message shows below. 
> 
> Is there another workaround or is it necessary to change package
> dependencies in the build environment?
> 
> Regards,
> Otto
> 
> Am Fri, 15 Jul 2016 08:52:23 -0500
> schrieb Carlos Cerdán <sig.up...@gmail.com>:
> 
> > Hi Otto:
> > 
> > Try uninstalling all QGIS stuff, even GRASS. After that, clean your
> > repositories and left just your prefered one; update and install again
> > QGIS.
> > 
> > That workaround was my salvation in similar cases (Ubuntu 1x.04 and QGIS
> > 2.x).
> > 
> > All the best
> > 
> > Carlos
> > 
> > 2016-07-15 8:27 GMT-05:00 Otto Dassau <das...@gbd-consult.de>:
> > 
> > > Hi Jürgen,
> > >
> > > yes, entry in /etc/apt/sources.list is
> > >
> > > deb http://qgis.org/ubuntugis-ltr trusty main
> > > deb http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu trusty
> > > main
> > > [...]
> > >
> > > error message is:
> > >
> > > The following packages have unmet dependencies:
> > >  libgeos-c1v5 : Breaks: libgeos-c1 (< 3.4.2-8~) but 3.4.2-4ubuntu1 is
> > > to be installed E: Error, pkgProblemResolver::Resolve generated breaks,
> > > this may be caused by held packages.
> > >
> > > Is it because there are still dependencies building and not yet
> > > available?
> > >
> > > Regards,
> > > Otto
> > >
> > > Am Fri, 15 Jul 2016 15:19:08 +0200
> > > schrieb Jürgen E. Fischer <j...@norbit.de>:
> > >
> > > > Hi Otto,
> > > >
> > > > On Fri, 15. Jul 2016 at 15:09:29 +0200, Otto Dassau wrote:
> > > > > trying to update QGIS packages (2.14.4) from ubuntgis-ltr
> > > > > repository on ubuntu 14.04 gives a dependency conflict.
> > > >
> > > > Did you also add the ubuntugis repository?
> > > >
> > > > Jürgen
> > > _______________________________________________
> > > Qgis-user mailing list
> > > Qgis-user@lists.osgeo.org
> > > List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
> > > Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user
> 
> _______________________________________________
> Qgis-user mailing list
> Qgis-user@lists.osgeo.org
> List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
> Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

_______________________________________________
Qgis-user mailing list
Qgis-user@lists.osgeo.org
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

Reply via email to