>>What do the qmail-send logs say? Did you look in ~alias/Mailbox for
>There are no messages from the ~alias/Mailbox for bounces.
>About qmail-send logs, I don't know where to find the log file,


>Now I have another problem, I cheked the
>/var/qmail/supervise/qmail-smtpd/run file and tried to edit it here
>is the file: 
>QMAILDUID=`id -u qmaild`
>NOFILESGID=`id -g qmaild`
>exec /usr/local/bin/softlimit -m 4000000 \
>    /usr/local/bin/tcpserver -v -p -x /etc/tcp.smtp.cdb \
>       -u $QMAILDUID -g $NOFILESGID 0 smtp /var/qmail/bin/qmail-smtpd 2>&1
>Then I saved it and restart qmail.....

Hmm. What did you change?

>After restarting, a repeated message appears on the screen:
>> softlimit: fatal: unable to run : file does not exist
>I don't know what it means, so I just ignore it and tried testing
>mail thru smtp. 

softlimit is saying it can't find /usr/local/bin/tcpserver.

>Now I can't even connect.

Of course not.


I was able to fix the error that appears on the screen, it just a typographical error 
for the qmail-smtpd/run file.
After that I restart qmail, then check the /var/log/mail, and I think is working fine 
with messages:

@40000000398e548b1b8e40ac delivery 1: success: 
@40000000398e548b1b964f2c status: local 0/10 remote 0/20
@40000000398e548b1cc63fc4 end msg 46350
@40000000398e563612687894 new msg 46350
@40000000398e563612698dec info msg 46350: bytes 216 from <> qp 868 uid 504
@40000000398e563612b52964 starting delivery 2: msg 46350 to local @samphil.sepco.com.ph
@40000000398e563612b690c4 status: local 1/10 remote 0/20
@40000000398e563612d290bc delivery 2: success: 
@40000000398e563612d3a22c status: local 0/10 remote 0/20
@40000000398e563612d4a014 end msg 46350

My testing only works with local. The one I followed with test.deliver. Then I tried 
the instructions for
test.receive, still, it's not working with smtp. I mean, I thought I was able to send 
it right with no errors,
but when I check the user's mailbox, there's no message only the message I told you 
I also tried to check for the ~alias Mailbox and .qmail-default, there are no 
messages. By the way, right now I just want 
to use qmail for our Internal network, so DNS is configured for localhost only, I mean 
I still haven't ask our ISP
to delegate the DNS to the server I'm setting up. Does this affect my testing in qmail 
using smtp? I think qmail should
work with this kind of setup, besides I'm just on the testing stage. Just like when 
you use sendmail, you could send
mail locally.

Thanks again,

for our internal network

Reply via email to