I run an ezmlm mailing list for a friend, which has always worked fine. The 
list is moderated and today the moderator tried to send a message to the list, 
but the moderator confirmation message didn’t reach her because her mail server 
blocked it (I checked and am not on any RBL lists, so have asked the ISP to 

Meanwhile, I tried to push the message awaiting moderation via the instructions 
from the ezmlm FAQ. ezmlm-accept dies with a segfault. When I try to run 
ezmlm-send directly, which ezmlm-accept does, again the segfault:

segfault at 0 ip 00000000004093d0 sp 00007ffe72c0e2e8 error 4 in 

The command line is (with LISTDIR replacing the name of the vpopmail directory):

/usr/bin/ezmlm-send LISTDIR < LISTDIR/mod/pending/1501468655.5150

I’ve also done it with fully-qualified paths for LISTDIR and it didn’t make any 

This is on centos 7, all packages and kernel/glibc/etc up to date. Everything 
else is working normally, no other signs of problems that I can see, nothing in 
/var/log/messages except the segfault line above. I reinstalled the ezmlm yum 
package to make sure no binaries were corrupted.

I haven’t a clue what to do, but I really need to get this message out. Once 
something hits a segfault, I’m pretty stuck. I’ve rebooted the server twice, 
also, which I hate doing; didn’t help.

Any ideas for either a fix or a workaround so I can get this message out?


Steve Linberg, Chief Goblin
Silicon Goblin Technologies
Be kind.  Remember, everyone you meet is fighting a hard battle.

Reply via email to