I had the same issue until I removed ALL instances of clamav. I'm not sure why the old version didn't take care of itself. By looking at your clamav *.so files it is evident that you have an older version of clamav that has not been removed. You need to remove it.  Run the command 'rpm -qa | grep clamav' and see if there is another instance of clamav installed. Check the lib your output was erroneous (below):

ls -l libclamav*
-rwxr-xr-x 1 root root    1037 Mar 30 01:48 libclamav.la <http://libclamav.la> lrwxrwxrwx 1 root root      18 Jun 18 12:59 libclamav.so -> libclamav.so.9.0.2 lrwxrwxrwx 1 root root      18 Jun 18 12:59 libclamav.so.9 -> libclamav.so.9.0.2
-rwxr-xr-x 1 root root 7293416 Feb  8 04:47 libclamav.so.9.0.1


The correct output would be something like the following (you were missing libclamav.so.9.0.2):

ls -l libclamav*
-rwxr-xr-x 1 root root    1037 Mar 30 01:48 libclamav.la <http://libclamav.la> lrwxrwxrwx 1 root root      18 Jun 18 12:59 libclamav.so -> libclamav.so.9.0.2 lrwxrwxrwx 1 root root      18 Jun 18 12:59 libclamav.so.9 -> libclamav.so.9.0.2
-rwxr-xr-x 1 root root 7293416 Feb  8 04:47 libclamav.so.9.0.2


On 6/20/2019 2:53 AM, ChandranManikandan wrote:
Hi Eric,

I have removed the existing one and tried above your advice, after install it hangs the package while installing for 30 mins, nothing happens.
Could you look at this issue and provide me the latest clamav patch.

Appreciate your help.

 yum install clamav-0.101.2-8.qt.zlib1211.el6.i686.rpm
Loaded plugins: fastestmirror, priorities, protectbase, refresh-packagekit,
              : replace, security
Setting up Install Process
Examining clamav-0.101.2-8.qt.zlib1211.el6.i686.rpm: clamav-0.101.2-8.qt.zlib121                     1.el6.i686 Marking clamav-0.101.2-8.qt.zlib1211.el6.i686.rpm as an update to clamav-0.101.1           -7.qt.zlib1211.el6.i686
Loading mirror speeds from cached hostfile
 * base: download.nus.edu.sg <http://download.nus.edu.sg>
 * epel: mirror.ehost.vn <http://mirror.ehost.vn>
 * extras: download.nus.edu.sg <http://download.nus.edu.sg>
 * qmt-current: ftp.whitehorsetc.com <http://ftp.whitehorsetc.com>
 * rpmforge: kartolo.sby.datautama.net.id <http://kartolo.sby.datautama.net.id>
 * updates: download.nus.edu.sg <http://download.nus.edu.sg>
 * webtatic: uk.repo.webtatic.com <http://uk.repo.webtatic.com>
26 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Resolving Dependencies
--> Running transaction check
---> Package clamav.i686 0:0.101.1-7.qt.zlib1211.el6 will be updated
---> Package clamav.i686 0:0.101.2-8.qt.zlib1211.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package
    Arch Version                   Repository              Size
================================================================================
Updating:
 clamav
    i686 0.101.2-8.qt.zlib1211.el6 /clamav-0.101.2-8.qt.zlib1211.el6.i686 9.8 M

Transaction Summary
================================================================================
Upgrade       1 Package(s)

Total size: 9.8 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : clamav-0.101.2-8.qt.zlib1211.el6.i686              1/2

On Wed, Jun 19, 2019 at 10:28 PM Eric Broch <ebr...@whitehorsetc.com <mailto:ebr...@whitehorsetc.com>> wrote:

    Chandran,

    check installed clam

    rpm -qa | grep clam

    turn off clamav in simscan

    remove all versions (rpm -e --nodeps clamav-'versions')

    download clamav from site (wget
    
ftp://qmailtoaster.org/pub/repo/qmt/CentOS/6/testing/i386/clamav-0.101.2-8.qt.zlib1211.el6.i686.rpm)

    install clamav (yum install clamav-0.101.2-8.qt.zlib1211.el6.i686.rpm)

    Let me know how it goes.

    Eric


    On 6/19/2019 7:03 AM, Eric's mail wrote:
    Ill take a look at the host where I built this binary and get
    back to you

    Get Outlook for Android <https://aka.ms/ghei36>




    On Wed, Jun 19, 2019 at 4:28 AM -0600, "ChandranManikandan"
    <kand...@gmail.com <mailto:kand...@gmail.com>> wrote:

        Hi Biju,

        I have downgrade clamav from 101.2 to 101.1.
        after downgrade tried restart the service, but still showing
        the below error.

        Stopping Clam AntiVirus Daemon:              [FAILED]
        Starting Clam AntiVirus Daemon: clamd: error while loading
        shared libraries: libclamav.so.9: cannot open shared object
        file: No such file or directory
                   [FAILED]

        then checked lib file with the below command.

        ls -l libclamav*
        -rwxr-xr-x 1 root root    1037 Mar 30 01:48 libclamav.la
        <http://libclamav.la>
        lrwxrwxrwx 1 root root      18 Jun 18 12:59 libclamav.so ->
        libclamav.so.9.0.2
        lrwxrwxrwx 1 root root      18 Jun 18 12:59 libclamav.so.9 ->
        libclamav.so.9.0.2
        -rwxr-xr-x 1 root root 7293416 Feb  8 04:47 libclamav.so.9.0.1

        Anything wrong in this source.
        Any one help me to resolve this issue.


        On Wed, Jun 19, 2019 at 2:01 PM Biju Jose | WHITES Systems
        <b...@whitesindia.com <mailto:b...@whitesindia.com>> wrote:

            Check the repo from where you are updating clamav.

            Best regards
            Biju Jose

            *From:*ChandranManikandan [mailto:kand...@gmail.com
            <mailto:kand...@gmail.com>]
            *Sent:* 19 June 2019 10:52
            *To:* qmailtoaster-list@qmailtoaster.com
            <mailto:qmailtoaster-list@qmailtoaster.com>
            *Subject:* [qmailtoaster] Re: clamav patch update issue

            Hi Friends,

            Anyone facing the similar issue?

            I have tried to update clamav with the below commands,
            after preparing it was struck the screen then i do ctl c
            then i run freshclam command it showing latest one. but
            the email was not going then i do simcontrol file
            clam=no, then it was going.

            Could you look at this issue and help me.

            i used this command on COS 6 32 bit.

            rpm -Uvh
            
ftp://qmailtoaster.org/pub/repo/qmt/CentOS/6/testing/i386/clamav-0.101.2-8.qt.zlib1211.el6.i686.rpm

            could you help to fix this issue.

            Do i need to revoke to older clamav version.

            Appreciate if anyone can help me.

            On Tue, Jun 18, 2019 at 1:18 PM ChandranManikandan
            <kand...@gmail.com <mailto:kand...@gmail.com>> wrote:

                Hi Folks,

                I have tried to update clamav with the below
                commands, after preparing it was struck the screen
                then i do ctl c then i run freshclam command it
                showing latest one. but the email was not going then
                i do simcontrol file clam=no, then it was going.

                Could you look at this issue and help me.

                i used this command on COS 6 32 bit.

                rpm -Uvh
                
ftp://qmailtoaster.org/pub/repo/qmt/CentOS/6/testing/i386/clamav-0.101.2-8.qt.zlib1211.el6.i686.rpm


--
                /*Regards,*/*/
                /Manikandan.C//*


--
            /*Regards,*/*/
            /Manikandan.C//*



-- */Regards,
        Manikandan.C
        /*



--
*/Regards,
Manikandan.C
/*

Reply via email to