Marek Marczykowski-Górecki:
> On Mon, Oct 17, 2016 at 11:08:35PM +0000, Emil Cronjäger wrote:
>> Marek Marczykowski-Górecki:
>>> On Mon, Oct 17, 2016 at 07:50:26PM +0000, Emil Cronjäger wrote:
>>> Take a look at those instructions (in order):
>> That got me a shell in one of the two VM's - thanx! There were some
>> problems with the ip-commands though, but I managed to get the data out,
>> and put it into a fresh VM.
>> The other VM (also standalone), however, wont help me with a shell:
>>      connected to domain [domain-name]
>>      error: operation failed: PTY device is not yet assigned
>> I am not sure or how to determine it, but it *might* be a debian-based
>> VM, if that is to any help.
> Standalone (PV) VM, right? Or maybe some HVM?

yes, standalone VM, no HVM.

>> It is not crucial for me to get the VM up and running, but I need to get
>> data out of it somehow.
> If you just want the data, create new VM, start it, and then attach the
> old VM private.img and/or root.img to the new one as additional device:
> qvm-block --attach-file new-vm /var/lib/qubes/appvms/old-vm/private.img

The command goes through without any errors, but the device doesnt show
up in new-vm. No changes in lsblk before/after.
I tried the --frontend=xvdi, also goes through with no problem, but
still no new device for me in new-vm. Does it hide somewhere special?

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To post to this group, send email to
To view this discussion on the web visit
For more options, visit

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to