On Tue, 15 Nov 2016 09:14:46 -0800 (PST), Grzesiek Chodzicki
<grzegorz.chodzi...@gmail.com> wrote:

> qvm-prefs does return true for installed_by_rpm, moreover using
> qvm-remove causes the "this package was installed by rpm" message to
> appear.

In that case I think I know what has happened.

You have tried to remove fedora-23 using dnf, while some appVMs still
were using it as a template. Dnf has displayed an error, but also it has
removed package, leaving it in qubes config (and not cleaning template's
directory).

The easiest (but not fastest, as it's time and network consuming) way to
fix it is to reinstall template and then remove it:

$ sudo qubes-dom0-update qubes-template-fedora-23
$ sudo dnf remove qubes-template-fedora-23

The hard, quick, and not sure if safe way is to edit 
/var/lib/qubes/qubes.xml file, find fedora-23 entry, and change its
installed_by_rpm property to "False" (it cannot be done by qvm-prefs).
Then remove it using qvm-remove:

$ qvm-remove fedora-23

Good luck,

-- 
yaqu

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20161115220701.C488D2055ED%40mail.openmailbox.org.
For more options, visit https://groups.google.com/d/optout.

Reply via email to