On Wed, 16 Nov 2016 01:14:24 +0100, Marek Marczykowski-Górecki
<marma...@invisiblethingslab.com> wrote:

> On Wed, Nov 16, 2016 at 12:28:17AM +0100, yaqu wrote:
> > > You have tried to remove fedora-23 using dnf, while some appVMs
> > > still were using it as a template. Dnf has displayed an error,
> > > but also it has removed package, leaving it in qubes config (and
> > > not cleaning template's directory).
> > 
> > Anyway, I think it should be considered as a bug.
> > 
> > Steps to reproduce (assuming fedora-23-minimal is not installed):
> > 
> > $ sudo qubes-dom0-update qubes-template-fedora-23-minimal
> > $ qvm-create -t fedora-23-minimal -l red test-vm
> > $ sudo dnf remove qubes-template-fedora-23-minimal
> 
> Yes, you're right. Previously (before Fedora introduced DNF), failure
> in %preun script aborted the operation, now it results just in a
> message. Not sure if this is a bug of a feature of DNF...

Removing package using plain rpm gives the same result, so it's not
dnf's fault.

There is an interesting entry in rpm changelog:
* Fix %preun scriptlet not aborting package erase
http://rpm.org/wiki/Releases/4.13.0

So it's fixed in rpm 4.13.0, but in dom0 we have broken rpm 4.13.0-rc1.

BTW it was fixed in commit:
https://github.com/rpm-software-management/rpm/commit/1ac507f15f014e69b926a1c2bf9a46a2a4dcaff3
And broken in:
https://github.com/rpm-software-management/rpm/commit/f4a49c3d446bb180ca6b30a4337065fb6511e641

-- 
yaqu

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20161116103152.2327120562A%40mail.openmailbox.org.
For more options, visit https://groups.google.com/d/optout.

Reply via email to