On Tue, Jun 27, 2017 at 08:29:24AM -0700, kennethjohns...@gmail.com wrote:
> On Friday, March 3, 2017 at 7:07:07 AM UTC-8, Unman wrote:
> > > As soon as the PRs are merged I'll post to the list, and you can try it
> > > then. (Or you could merge them yourself of course, and try the build.)
> > > Testing and feedback would be much appreciated.
> > > 
> > > I've been using Xenial for a while and it seems fine.
> > 
> > PRs are merged, to master if nor 3.2
> > 
> > This means that both Xenial and Trusty should build straight.
> > 
> > Set up a build environment as per docs.
> > 
> > git clone  https://github.com/QubesOS/qubes-builder
> > cd qubes-builder
> > ./setup (select builder-debian and trsut/xenial variants, deselect
> > fed23)
> > edit builder.conf, changing RELEASE:=3.2 to RELEASE:=master
> > make switch-branch (to get latest and greatest versions of components)
> > make qubes-vm
> > make template
> > 
> > cheers
> > 
> > unman
> Is this still usable today? I switched the branch to master and I went from 
> having a failure in debootstrap at the make template stage to a failure at 
> the make qubes-vm stage. 
> To be clear the debootstrap.log was showing an entry "chroot: failed to run 
> command 'mount': No such file or directory" where I could see mount was in 
> the /bin dir when I mounted and checked.
> This issue in make qubes-vm appears to happen because core-agent-linux cannot 
> find files.
> ...
> make[1]: Entering directory `/home/user/qubes-src/core-agent-linux'
> dh_install --fail-missing
> cp: cannot stat 
> 'debian/tmp/lib/systemd/system/avahi-daemon.service.d/30_qubes.conf': No such 
> file or directory
> dh_install: cp -a 
> debian/tmp/lib/systemd/system/avahi-daemon.service.d/30_qubes.conf 
> debian/qubes-core-agent//lib/systemd/system/avahi-daemon.service.d/ returned 
> exit code 1
> make[1]: *** [override_dh_install] Error 2
> make[1]: Leaving directory `/home/user/qubes-src/core-agent-linux'
> ...
> One thing I tried doing in an prior run was git checkout v3.2.18 as per 
> https://github.com/QubesOS/qubes-core-agent-linux/releases/tag/v3.2.18 
> running on a hunch that the 4.0 code is messing with something which did 
> indeed work and it continued on. v3.2.18 is the last v3 release you guys 
> have. But shortly after it failed in another module. I followed the same 
> steps, checked out a v3 version and it continued on. did that I think one 
> more time and make qubes-vm finishes. 
> Now I run make template and.... fails in debootstrap same as initially. 
> Is there an Ubuntu guide out there that is relevant and works? I have been 
> scouring the web for 3 days now trying to get a trusty and xenial template 
> built.

I think you need to work on your search skills :-) 
The same question was asked on this list 3 days ago.
The mount error arises because 'mount' isn't on the path - copy the
export PATH statement from template_debian/vars.sh to
template_qubuntu/vars.sh, and you should be good to go.

The build on master is crocked for the moment.
Note that the PRs are all merged to 3.2, and you can therefore build on
3.2 without any problem. 
The simplest way to do this is to set RELEASE := 3.2 , and then 'make

There's really no need for a special Ubuntu guide - the standard
instructions for using qubes-builder in
www.qubes-os.org/doc/qubes-builder explain the basics.
Obviously if you just want to build a template, then 'make qubes-vm' and
'make template' suffice.
Otherwise, there's the illustrated guide to building an Arch Template in
the docs.


You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to