On Saturday, November 25, 2017 at 11:11:30 PM UTC-5, Wael Nasreddine wrote:
> On Saturday, November 25, 2017 at 8:06:27 PM UTC-8, Person wrote:
> > “In an earlier install, after I got this error, I switched all VMs to using 
> > pv virt_mode and managed to get `qubes-dom0-update` to run, after doing 
> > that, I still got the same weird /proc/cpuinfo and lscpu output but VMs 
> > were booting OK with hvm.”
> > 
> > How exactly do you switch VMs to using pv virt_mode? The only thing I 
> > actually want is for the VMs to book correctly, and that would save me a 
> > lot of trouble.
> 
> sudo qvm-prefs <VM_NAME> virt_mode pv

I tried the command on my only HVM, and I received the message: 
***Running the tool as root is strongly discouraged, this will lead you in 
permissions problems. Retry as unprivileged user or use "--force-root" to 
continue anyway.
I wasn't using root user at the time, so I found that strange. And after I 
changed the HVM to pv virt_mode, I got the same virtualization error.

I then tried the command on every single VM. I still received the 
"--force-root" message, but there were no other errors in the command. When I 
submitted the commands, I received lists of information about the VMs. And when 
I changed them to pv virt_mode, I still got the same virtualization error. 

(If dom0 doesn't say that the command was unsuccessful, it was successful, 
right? Otherwise, I may not have successfully set the VMs to pv virt_mode.)

It seems that we have different versions of Qubes (you have Qubes 4.0 and I 
have Qubes 3.2), so I can see why your method might not work for me.
 

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/c5a3a98e-70ab-4c31-b87a-5ad31c87d3eb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to