I tried to send this question from the email address I used to subscribe to the 
user group, but it's been about two hours and it hasn't shown up. I'm assuming 
it's a Google thing, but I apologize if this question shows up twice.

So, here I go again.  I'm a newbie with Qubes, but I love the idea.  I tried 
installing 3.2 some time ago, but had hardware difficulties, so I decided to 
give 4.0 a try.  

I currently have a Dell Inspiron 5759 laptop, System BIOS 1.3.0, ePSA build 
4304.09 UEFI ROM, Intel i7-6500u cpu, secure boot disabled, Intel SGX 
disasbled, fast boot set to "thorough" (though the same results occur with it 
set ot "auto").  It is set up as dual boot with KDE Neon linux and Windows 10.

I decided to give Qubes 4.0 rc3 a go. When I play with a new distro, I usually 
start by installing it on an external hard drive, so I can make sure it plays 
well with others without having to destroy my current working setup.  That's 
what I tried here.  I attempted to install it on a Western Digital 2 TB 
external portable drive.

I downloaded the OS, created the installation flash drive, and chose the 
external drive as the drive to install on.  It seemed to go fine.  No warnings, 
no hangs.  I installed using the default partitioning, with the exception that 
I resized the / directory to make it a little smaller and added a vfat /data 

When I rebooted and hit F12 for the boot sequence options, sure enough "Qubes" 
was one of them.  Qubes *doesn't* show up in the boot options if it gets to the 
grub boot list, that's still just neon and windows. But, if I use the BIOS boot 
sequence, Qubes is an option.  

I chose "Qubes" as the option, and it dumped me into a BIOS screen that said it 
was checking the safety of hardware, which it apparently passed, but then came 
up and said it couldn't boot (though I did not write down the exact error 
message, unfortunately).  I rebooted again, did the boot sequence thing, and it 
came up with a black screen with the options:

"Press F1 to reboot"
"Press F2 to reboot into setup"
"Press F5 to run onboard diagnostics"

And each button did exactly that.

I then tried to boot on USB using legacy boot, but that came up with "no boot 
device found."

Booting into neon or windows still works fine.  I can mount the external drive 
and see all the normal linux stuff that a distro should have.  I can read and 
write to both the / and /data partitions on the drive with root permissions.

I tried changing usb ports, and that didn't do anything.  I tried installing 
with and without disk encryption, and that didn't change anything except that I 
couldn't mount the encrypted / partition in neon.

Is this some problem with having a /boot/efi on the external drive *and* a 
/boot/efi on the internal drive?  If so, why does it not work on an 
installation but seems to work on the installation flash drive?

Anybody have pointers to what I should try next? 



You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to