On 10/19/20 9:58 AM, Stumpy wrote:
On 10/17/20 6:17 PM, Jarrah wrote:

I just tried to install qubes-tunnel in a fedora template and that
also didnt work,

sudo dnf install qubes-repo-contrib && sudo dnf install qubes-tunnel

Try with `dnf install --refresh --enablerepo=qubes-repo-contrib
qubes-tunnel`. It may be that either the new metadata hasn't come down
(happens a lot on Debian, not so much fedora) or the repo isn't enabled
by default in the package.

Thanks for the suggestion, I get pretty much the same kind of error (in the template and in dom0 when trying to install rofi)

bash-5.0# sudo dnf install --refresh --enablerepo=qubes-repo-contrib qubes-tunnel
Error: Unknown repo: 'qubes-repo-contrib'

yet when I installed something (Sakura in this case) it clearly showed it was checking the contrib repo in addition to the other repos?

1. The reason you're getting "Error: Unknown repo" is that the repository name is not "qubes-repo-contrib". Rather, the name depends on your Qubes release and whether it is in dom0 or a TemplateVM. For example, in a Fedora VM on Qubes 4.0, the new repository is:


2. After I installed the repository in a Fedora VM, I checked and found that it was already enabled, so --enablerepo is unnecessary.

3. I then tried to install the "qubes-tunnel" package in the same VM. Even though dnf reported that the contrib repo was checked, the "qubes-tunnel" package was not found. So, I can at least partially reproduce this. However, I don't know whether this problem is specific to the "qubes-tunnel" package.

I suggest filing a bug report.

Andrew David Wong (Axon)
Community Manager, Qubes OS

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 

Attachment: OpenPGP_signature
Description: OpenPGP digital signature

Reply via email to