On Thursday, 24 March 2022 12:39:27 GMT 'Johannes Graumann' via qubes-users 
> > On 24.03.2022 12:16 'Johannes Graumann' via qubes-users
> > <qubes-users@googlegroups.com> wrote: ...
> > As the laptop's HDMI port also does not work (likely due to being
> > hardwired to the NVDIA card), I currently have no means of setting up
> > multiple screens.
> > 
> > I want to use Qubes and this machine as my daily driver and non
> > functioning dock as well as the lack of a multiple screen options are
> > show stoppers for this. The latter is possibly fixable through NVIDIA
> > support in `dom0` and that's what I'm working on next, but I would highly
> > appreciate any hint on how to get the dock working.
> Installing `kernel-latest` in `dom0` (which currently brings in 5.16) and
> setting graphics to `discrete` in the BIOS renders the on board HDMI port
> active. `Hybrid` graphics settings results in a black screen when the
> display manager comes up.

Interesting. I am on a P1 gen4 with a nVidia card (so, a similar hardware 
config), and I simply cannot get any X when using the "discrete" UEFI setting.

In "hybrid" mode, initially `kernel-latest` here also meant no X. Only after 
creating an `xorg.conf` file and *explicitly* setting "modesetting" driver for 
the integrated card I got X to work with `kernel-latest`. X was working out of 
the box with the original kernel though in "hybrid" mode (I am guessing some 
timing changes leading to card initialization happening in different order or 
some such).

HDMI ports refuse to work in X regardless of what I do. Tried the binary 
driver, tried nVidia modesetting, tried nouveau. Tried "hybrid", tried 
"discrete". To no avail. Best I got was the Qubes loading screen and FDE 
password prompt on the external monitor -- both in "hybrid" and "discrete", 
only with binary driver and nVidia modesetting.

Enabling nVidia binary driver and configuring it in `xorg.conf` always ends in 
this line in `Xorg.0.conf`:
> Failed to allocate push buffer

What a mess!


You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 

Reply via email to