Stephen Lombardo wrote:
Hi Mohit,
In many cases "unable to open database file" errors in sqlite are symptoms
of a permission problem where the process can't write to the data file or
create temporary files (sqlite does this quite often, see
http://www.sqlite.org/tempfiles.html). Can you check the permissions on the
database file, it's containing directory, and your systems temp directory?

Thanks Stephen

I'm on Windows, logged in as admin - can't think of anything related to permissions. I just tried looking around anyway to see if anything is created... but nothing that helps so far!

The other issue is that I get these errors randomly on different lines of the rake db:migrate

While typing this message, I decided to see what else may be wrong. I was worried that it may have something to do with the version of sqlite3 that's being used. I updated the path to only access ruby/bin and windows/system32 (sqlite3.dll is there). But, still no go!

rake aborted!
SQLite3::SQLException: unable to open database file: DROP TABLE page_parts

Does this mean that for some reason it is trying to open a file called 'DROP TABLE page_parts'?

Cheers,
Mohit.
8/12/2008 | 1:22 AM.


_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to