Andrew Neil wrote:

On 28 May 2009, at 05:20, Mohit Sindhwani wrote:

Mohit Sindhwani wrote:
Andrew Neil wrote:
I've just ran into this problem too, whilst trying to upgrade a site from Radiant 0.6.9 to 0.7.1. I found that I could not run `rake radiant:update`. I kept getting a message like:

can't activate rspec (= 1.1.12, runtime), already activated rspec-1.2.6

I found that uninstalling all rspec versions greater than 1.1.12 made the problem go away.
Actually, is there any way to solve this problem other than uninstalling all versions other than 1.1.12? I would like to play with the current developments of rspec (since I just bought the rspec book) but my reliance on Radiant is more...

I agree that un-installing more recent versions of rspec seems like a drastic measure, but it was the only thing I tried that would work. Prior to that, I tried each of the following without success:

* Adding the line: config.gem "rspec", :version => "1.1.12" to the environment
* Unpacking rspec-1.1.12 into vendor/gems/

It was only necessary to uninstall rspec so that I could run the task `rake radiant:update`. Once this task had run, I found that I could re-install the most recent version of rspec (currently 1.2.6), and it didn't seem to cause any further conflict.
That's interesting - I got the "already activated..." error when I did script/server -e production -p 3700

Hmm...

Cheers,
Mohit.
5/28/2009 | 4:57 PM.

_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to