Hi.
I'm trying to install radiant cms but after I run it with ./script/
server and go at / I got the following backtrace:

=================================
 ArgumentError in SiteController#show_page

comparison of String with 60 failed

RAILS_ROOT: /home/alex/test
Application Trace | Framework Trace | Full Trace

/home/alex/.gems/gems/radiant-0.9.1/vendor/radius/lib/radius/parser/
scan.rb:421:in `<'
/home/alex/.gems/gems/radiant-0.9.1/vendor/radius/lib/radius/parser/
scan.rb:421:in `block in perform_parse'
/home/alex/.gems/gems/radiant-0.9.1/vendor/radius/lib/radius/parser/
scan.rb:417:in `loop'
/home/alex/.gems/gems/radiant-0.9.1/vendor/radius/lib/radius/parser/
scan.rb:417:in `perform_parse'
/home/alex/.gems/gems/radiant-0.9.1/vendor/radius/lib/radius/parser/
scan.rb:22:in `operate'
/home/alex/.gems/gems/radiant-0.9.1/vendor/radius/lib/radius/parser.rb:
37:in `tokenize'
/home/alex/.gems/gems/radiant-0.9.1/vendor/radius/lib/radius/parser.rb:
29:in `parse'
/home/alex/.gems/gems/radiant-0.9.1/app/models/page.rb:302:in `parse'
/home/alex/.gems/gems/radiant-0.9.1/app/models/page.rb:307:in
`parse_object'
/home/alex/.gems/gems/radiant-0.9.1/app/models/page.rb:127:in `render'
/home/alex/.gems/gems/radiant-0.9.1/app/models/page.rb:117:in
`process'
/home/alex/.gems/gems/radiant-0.9.1/app/controllers/site_controller.rb:
62:in `process_page'
/home/alex/.gems/gems/radiant-0.9.1/app/controllers/site_controller.rb:
21:in `show_page'
====================================================

I don't understand what I'm doing wrong. I have ruby 1.9.1 and latest
radiant installed via gems. Note that the admin (/admin) panel works
fine

Reply via email to