There is an old radiant site I'm trying to get working (again) on Dreamhost.

The error on the web site is:

-----------------
 The application has exited during start-up (i.e. during the evaluation
of config/environment.rb). The error message can be found below. To
solve this problem, please follow any instructions in the error message.

Error message:
    Your config/boot.rb is outdated: Run "rake rails:update".
------------------

yes but....

All this depends on which version of rails, ruby ....

I THINK is is 0.8.1 or 0.9.1

I *seems* that there is no copy of the relevant revision of rails under
/vendor/

Which version rake to run
The one in /usr/bin or the one in ~/.gems/bin ?

---------------
$ /usr/bin/rake rails:update
rake aborted!
uninitialized constant Rake::DSL
~/.gems/gems/radiant-0.9.1/Rakefile:4
----------------
$ ~/.gems/bin/rake rails:update
WARNING: 'require 'rake/rdoctask'' is deprecated.  Please use 'require
'rdoc/task' (in RDoc 2.4.2+)' instead.
    at ~/.gems/gems/rake-0.9.2.2/lib/rake/rdoctask.rb
rake aborted!
Don't know how to build task 'rails:update'
--------------

I'm lost ...










-- 
"If you spend more on coffee than on IT security, then you will be hacked.
 What's more, you deserve to be hacked."
   - Richard Clarke, the special adviser to the president on cybersecurity

Reply via email to