On Wed, Aug 1, 2012 at 10:17 AM, Anton J Aylward
<radi...@antonaylward.com> wrote:
> There is an old radiant site I'm trying to get working (again) on Dreamhost.
>
> The error on the web site is:
>
> -----------------
>  The application has exited during start-up (i.e. during the evaluation
> of config/environment.rb). The error message can be found below. To
> solve this problem, please follow any instructions in the error message.
>
> Error message:
>     Your config/boot.rb is outdated: Run "rake rails:update".
> ------------------
>
> yes but....
>
> All this depends on which version of rails, ruby ....
>
> I THINK is is 0.8.1 or 0.9.1
>
> I *seems* that there is no copy of the relevant revision of rails under
> /vendor/

Is there a copy of Radiant in vendor/radiant?

If not, check which version of the radiant gem you have and copy the
source to vendor/radiant.

If things are screwed up, you may not be able to run rake tasks
without running into errors like these. So putting a copy of Radiant
in vendor/radiant will at least freeze the initialization to that
copy. Radiant looks there first before looking to the gems you have.

>
> Which version rake to run
> The one in /usr/bin or the one in ~/.gems/bin ?
>
> ---------------
> $ /usr/bin/rake rails:update
> rake aborted!
> uninitialized constant Rake::DSL
> ~/.gems/gems/radiant-0.9.1/Rakefile:4
> ----------------
> $ ~/.gems/bin/rake rails:update
> WARNING: 'require 'rake/rdoctask'' is deprecated.  Please use 'require
> 'rdoc/task' (in RDoc 2.4.2+)' instead.
>     at ~/.gems/gems/rake-0.9.2.2/lib/rake/rdoctask.rb
> rake aborted!
> Don't know how to build task 'rails:update'
> --------------
>
> I'm lost ...
>

Don't attempt to update Rails for the project.

It appears as if you have Radiant 0.9.1, but run "gem list radiant" to
see what versions are on your server.
It's possible that the site was started with 0.8.1 (for example) but a
newer gem was later installed.

Try setting up vendor/radiant and let us know what happens then.

If you get different errors that means your changes did something. If
you keep getting the same error, then the problem might be elsewhere.

If you are successful in moving along, check out this gist where I
created instructions for upgrading https://gist.github.com/1540782

I'll update that with any details that you provide to help clarify the process.

-Jim


-- 
Write intention revealing code #=> http://www.clean-ruby.com

Jim Gay
Saturn Flyer LLC
571-403-0338

Reply via email to