Hi Jeremy Wadsack! I'm answering your msg dated 02:03 PM 8/17/2005:
>The second message is an odd bug. Perhaps you are using quotes in the
>output filename where they are not needed?

I have tried it both ways, Jeremy. I was using quotes initially for the paths 'cause of the space in "Program Files", but wasn't sure if it needed it or not. However, right now the .ini is set to look for the dat file right in the reportmagic folder (c:\program files\reportmagic) but there's NO path at all, just the file name. And yes, the file is physically located in that folder. It throws this error: >>

mkdir "C:\: Invalid argument at rmagic.pl line 720

[later] Interesting. It does NOT like having my .dat listed as a plain file name, even when I renamed it to sample.dat just for fun. However, I appended a slightly different path to my various file name params, i.e., c:\progra~1\reportmagic\july2005.dat, no quotes, and it produced a report!

Looks like it doesn't like the spaces, but why didn't it like it when it was a pathless file name, I wonder? It was right in the same folder as rmagic.exe and the original sample report, with the correct name, shouldn't it have resolved it correctly? Oh well, it seems to be working now, so I'll drop back into obscurity :) :)

Thanks!

elaine

>The first message usually means a permissions error or that the file
>does not exists. It's not a problem parsing the file, but getting read
>access to the named file.




>--
>Jeremy Wadsack
>Seven Simple Machines
>
>
>EPPack wrote:
>
>> Brand new to both Analog 6.0 and ReportMagic, but I somehow succeeded
>> in creating first a "normal" html report, then later, a dat for use by
>> RM. Problem is that RM is not recognizing the dat format, best I can
>> tell. For testing purposes and simplicity I copied the dat directly to
>> the RM folder, modified the rmagic. ini file accordingly to show my
>> dat file name, july2005.dat, with no pathing, but when I try to run a
>> report, I get this message:
>>
>> C:\PROGRA~1\ReportMagic>rmagic
>> Report Magic 2.21
>> Copyright (C) 1999-2003 Wadsack-Allen. All rights reserved.
>> rmagic: Beginning report creation (Wed Aug 17 12:59:43 2005).
>> rmagic: --> Settings file: .\rmagic.ini.
>> rmagic: --> Input data file: july2005.dat.
>> rmagic: ERROR: -- Can't read from the data file: july2005.dat --
>>
>> or alternatively, sometimes this one, depending on how I've tweaked it:
>>
>> C:\PROGRA~1\ReportMagic>rmagic
>> Report Magic 2.21
>> Copyright (C) 1999-2003 Wadsack-Allen. All rights reserved.
>> rmagic: Beginning report creation (Wed Aug 17 12:59:54 2005).
>> rmagic: --> Settings file: .\rmagic.ini.
>> rmagic: --> Input data file: july2005.dat.
>> mkdir "C:\: Invalid argument at rmagic.pl line 720
>>
>> The statistics portion of the .ini file is this:
>>
>> [statistics]
>> File_In = july2005.dat
>> Frame_File_Out = index.html
>> Format= XHTML 1.0
>> No_Robots = 1
>> Log_File = rmagic.log
>> Always_Quit = 1
>> Language = en
>> Verbose = NWE
>>
>> The error messages are less than helpful, since there's no indication
>> what the problem actually is. My dat file appears to be similar to the
>> sample.dat file, at least it's certainly not a normal report, but I'm
>> at a loss to figger out what to try next. Can anyone assist?
>>
>> Thanks!
>>
>> elaine pack
>> Charlottesville, VA
>>
>
>_______________________________________________
>This is the reportmagic-help mailing list
>To change your subscription or other preferences use this URL:
>   http://reportmagic.org/cgi-bin/mailman/listinfo/reportmagic-help
>
>


_______________________________________________
This is the reportmagic-help mailing list
To change your subscription or other preferences use this URL:
  http://reportmagic.org/cgi-bin/mailman/listinfo/reportmagic-help

Reply via email to