I had some fun and frustration this morning configuring a new server
environment. I mistakenly tried to use variable names like "foo.bar"
and "foo-bar" in some <resin:set /> statements. Those didn't work.
Instead, <resin:set var="foo_bar" value="baz" /> does work.

Was this a convention I should have known? It occurs to me now that
these statements feel a lot like EL, and perhaps the "foo.bar" was
trying to call a foo.getBar(), and "foo-bar" might be evaluated as a
mathematical expression.

<resin_documentation_flame>
If there are restrictions to how variables can be named, it would be
very helpful to find those spelled out in the documentation.
Additionally, I found resin documentation with typos related to the
set xml structure (interesting variable declarations, missing '/>',
and no explanation of 'value' versus 'default').
</resin_documentation_flame>

Overall we do enjoy using resin. It's these hidden gems of frustration
that keep us on our toes.

+ jay


_______________________________________________
resin-interest mailing list
resin-interest@caucho.com
http://maillist.caucho.com/mailman/listinfo/resin-interest

Reply via email to