Hi list.
I have my J2EE webapp on an external hard drive, which I carry between
my office and my home computer.
On each computer - running Windows XP and Java 1.5 - I have a Resin
(3.0.22) installation and a shortcut to start Resin with the server root
on the external drive.
This has worked flawlessly for over a year.

Now suddenly (ok, after returning from vacation), the application is
immensely slow - on one of the computers!
Starting Resin and the application now takes anywhere from 3 to 5
minutes on my home computer, compared to the usual 30 or so seconds.
Loading a simple page can take 40 seconds. It seems that most of the
time is spent inside the disk access of the dependency checking.
(Turning dependency checking off was much faster, but still slower than
normal).
I tried to copy the project to the internal drive to see if there was
some interface hardware issue - no difference.
I profiled the application with JProfiler, and it thinks there is a
hotspot in com.caucho.vsf.JniStream.read(). Why...?

I am running out of ideas on what could be wrong and how to track it down.

Any tips would be much welcome!

  /Mattias


_______________________________________________
resin-interest mailing list
resin-interest@caucho.com
http://maillist.caucho.com/mailman/listinfo/resin-interest

Reply via email to