I tried to use the eclipse environment to run this little sample with 
the help of Steffen Busch, but I continue to have the error:

com.caucho.amber.AmberRuntimeException: 'adlhessian.Ejbuser' with 
classloader EnvironmentClassLoader[web-app:http://localhost:8000] is an 
illegal instance class

Riccardo Cohen wrote:
> hi again
> I'm really blocked with my developments, can somebody help me with this 
> strange problem ? I can send the source it is very small and the error 
> is systematic.
> Thanks a lot.
> Riccardo Cohen wrote:
>> ok thanks for the <url> info.
>> Now for the amber problem : I cleaned all including work directory, 
>> after first run, found a .class for all my ejbs (in classes folder). In 
>> work/pre-enhance folder I have the following files :
>> Ejbuser__ResinExt.class
>> Ejbuser__ResinExt.java
>> Ejbuser.class
>> and nothing in work/ejb
>> I dont' know if the files are valid, but the applications does not work, 
>> and continue to try to recompile if I request it.
>> I tried to add <load-on-startup/> for the servlet that uses that ejb, 
>> but it did not change. I also tried to put the whole application in 
>> webapps/ROOT in resin folder, but no success.
>> The error is systematic.
>> would you like me to send you the full app folder ?
>> Scott Ferguson wrote:
>>> This is much more complicated.  Amber does bytecode enhancement at the  
>>> classloader level, so there are complicated timing issues.   
>>> Specifically, if something loads the Ejbuser class before Amber has  
>>> configured it, you'll get the non-enhanced class.
>>> There might also be some cases where an error in generating the  
>>> enhanced class might not get logged properly.  Does the log show any  
>>> kind of error?  Also, is there a valid file in WEB-INF/work/pre-enhance?
>>> -- Scott

Très cordialement,

Riccardo Cohen
149 av Général de Gaulle
37230 Fondettes - France
tel : 02-47-49-90-49
fax : 02-47-49-91-49

resin-interest mailing list

Reply via email to