We recently updgraded from Resin 3.0.23 to 3.1.6.  We use Struts 1.2.8.
We are currently getting the following exception,


"Unhandled exception
A-INF/tlds/struts-logic.tld:10: 'tlibversion' is an unknown property of


Here's the top of struts-logic.tld:

<!DOCTYPE taglib PUBLIC "-//Sun Microsystems, Inc.//DTD JSP Tag Library
1.1//EN" "http://java.sun.com/j2ee/dtds/web-jsptaglibrary_1_1.dtd";>






I know the JSP 1.2 DTD changed the tag to <tlib-version> instead of
<tlibversion>.  Does Resin 3.1.6 not compatible with JSP 1.1?   


Another possibility I've considered is the case-sensitivity of the
getters.  The getter in com.caucho.jsp.cfg.TldTaglib is
getTlibVersion(), should it be getTlibversion() instead?  When we
upgraded to 3.1.6 we had to change a bunch of our JSP to match the case
of the property getters.

resin-interest mailing list

Reply via email to