Well, that seems to have done it!

I'd tried that in days gone by, and found it didn't work, but perhaps I
wasn't being sufficiently scientific and had made some other mistake

Thanks very much, Aaron, I really appreciate it.


On Wed, Mar 4, 2009 at 2:00 PM, Aaron Freeman <aaron.free...@layerz.com>wrote:

>  Perhaps the key-store-file gets read by a different class at startup than
> it does at runtime.  Have you tried using an absolute path in the
> key-store-file? I use JSSE and only have the three nodes you show below.
> Aaron
> *From:* resin-interest-boun...@caucho.com [mailto:
> resin-interest-boun...@caucho.com] *On Behalf Of *Michael Prescott
> *Sent:* Wednesday, March 04, 2009 12:46 PM
> *To:* General Discussion for the Resin application server
> *Subject:* [Resin-interest] Resin won't start with JSSE enabled
> My resin instance won't start if JSSE is enabled in the configuration, but
> I can't figure out what the problem is.  (Yes, I'm aware of the advice for
> using OpenSSL instead, but that's not an option for me for the time being.)
> And yet, if I enable JSSE *while resin is running*, it appears to work
> correctly.
> The failure message (e.g. as a result of running *service resin start*) is
> this:
> Stopping resin:/usr/local/web/conf/resin.xml:85::
> java.io.FileNotFoundException: .
> Line 85 is the line just inside my <http> tag where I've made my <jsse-ssl>
> declaration, which looks like this:
> <jsse-ssl> <!-- line 85 -->
>   <key-store-type>jks</key-store-type>
>   <key-store-file>keys/mykeystore.jks</key-store-file>
>   <password>mypassword</password>
> </jsse-ssl>
> I've verified that it's finding the key store okay (when I change the path
> to the <key-store-file>, I get a different error explaining that it can't
> find this file).
> One version of the resin 
> docs<http://www.caucho.com/resin/doc/port-tags.xtp#jsse-ssl>states that the 
> <key-manager-factory> and <verify-client> values are
> mandatory, but I can't find any hints at legal values for this parameter in
> the Resin documentation.
> Nevertheless, if I comment out JSSE and start resin, I can get SSL going by
> uncommenting JSSE while resin is running.  It gets going without any
> complaints and indeed my site is accessible via SSL.  But obviously this is
> no good, since resin won't automatically start when it's configured in this
> way.
> I'd appreciate any hints or ideas as to what's going on.
> Regards,
> Michael
> _______________________________________________
> resin-interest mailing list
> resin-interest@caucho.com
> http://maillist.caucho.com/mailman/listinfo/resin-interest
resin-interest mailing list

Reply via email to