The problem is that patch.exe isn't in the path that Apache is seeing. Did
you add it to the Path in the System properties and then restart the

Where did you install patch.exe?


Christian Hammond - chip...@chipx86.com
Review Board - http://www.review-board.org
VMware, Inc. - http://www.vmware.com

2009/8/18 王振钢 <zgwan...@hotmail.com>

>      Manual server updates required A recent change requires manual
> updates to be made on this server. After these changes are made, you should
> restart your server.
> To keep track of future updates, please visit the Required Server 
> Updates<http://code.google.com/p/reviewboard/wiki/RequiredServerUpdates>page, 
> or subscribe to the mailing
> list <http://groups.google.com/group/reviewboard>.
>   Install GNU patch.exe GNU patch.exe must be in your executable search
> path for the diff viewer to work.
> You can install GNU patch.exe by downloading and running the 
> installer<http://gnuwin32.sourceforge.net/downlinks/patch.php>.
> Then add the directory containing patch.exe to the system PATH (Start >
> Control Panel > Advanced > Environment Variables > System Variables > PATH).
> Hi Christian,
> This is the page i see.
> My installation process:
> -install python 2.5 and mod_python
> -install mysql
> -install GNU patch.exe
> -install the setup tools, easy install reviewboard from cmd line.
> -build the site by rbsite install from the source code directory with is
> checked from http://reviewboard.googlecode.com/svn/trunk/reviewboard
> I answered all the questions during installation, and it tells the site has
> been installed.
> -include the site config file to the main apache config file
> The when I open the explorer to access this site, above page comes up. And
> it instructs me to run manage syncdb
> So I run  this command from the souce directory, but there's no
> settings_local.py, so i copied one from the site directory, and i run the
> command again, it seems no evolution required.
> But the 'Manul server updates required' is still there.
> Can you find what I did wrong?
> Regards!
> ------------------------------
> From: chip...@chipx86.com
> Date: Tue, 18 Aug 2009 02:41:28 -0700
> Subject: Re: Review board installation problem
> To: reviewboard@googlegroups.com
> Hi,
> There's several "Manual server updates required" pages. Which one are you
> seeing? What instructions is it providing?
> How did you install Review Board from SVN?
> Christian
> --
> Christian Hammond - chip...@chipx86.com
> Review Board - http://www.review-board.org
> VMware, Inc. - http://www.vmware.com
> On Tue, Aug 18, 2009 at 2:21 AM, snowman <zgwan...@hotmail.com> wrote:
> Hello, I'm a new guy to this review board tool. I get the annoying
> page 'Manual server updates required' page when I finish the
> installation process. My server configurations are windows xp,
> python2.5, apache2.2.4
> My souce code is checked out from the svn, it shoud be fresh. and I
> change the database from mysql to sqlite, no one works!
> Command manage.py syncdb has been run, but seems no evolution
> required! Can some one help me out?
> >

You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to