On Friday 01 January 2010 09:21:31 Brad Hards wrote:
> So I tried running "setup.py install" in the reviewboard checkout. It
> appears that it can't find a suitable version of djblets, even after I
> tried installing (again with "setup.py install") the git version.of
>  djblets. The "setup.py install" of reviewboard ends with:

> No local packages or download links found for Djblets>=0.5.7
> error: Could not find suitable distribution for
>  Requirement.parse('Djblets>=0.5.7')
I hacked around this by changing the the version information in the git 
version of djblets and installing that.

I could then run "setup.py install" for reviewboard, and it installed OK.

I started the devserver, and logged into reviewboard. Still no SCM tools, but 
I ran the "./reviewboard/manage.py registerscmtools" command and got back 
lines that told me "New SCM Tool X (reviewboard.scmtools.x.XTool" for X in 
Subversion, Git, Bazaar, CVS, Perforce, Clear Case and Mercurual.

Restarted the devserver, and I now see the various tools when I go to Add 
Repository. I filled it in with 
Name: OpenChange
Show this repository selected
Hosting service: Custom
Repository type: Subversion
Path: http://svn.openchange.org/openchange
Mirror path, Username, Password all empty
Use hosting service's bug tracker not selected
Type: None
Encoding left empty

When I press Save, I now get a message at the top of the screen (just under 
"Add repository" and above "General Information") says:
[Icon of red circle with white hyphen] "Please correct the error below."
[Icon of yellow/orange triangle with white exclamation mark] "global name 
'logging' is not defined"


Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to