We have 1.5 beta 2 installed there. I guess it should be fine to use 1.5
API.

Where can I find the documentation for the new API?

On Thu, Jul 15, 2010 at 11:13 PM, Christian Hammond <chip...@chipx86.com>wrote:

> Hi Aleix,
>
> Off-hand, I don't know why it'd be problematic, but I'd recommend setting
> up a little development server on your box, set DEBUG = True in your
> settings_local.py, and testing it there. We should be able to better see
> what the error is that way, along with lots of debug information.
>
> We try to return JSON payloads for everything, but a 500 error can happen
> when something internally breaks. That'd definitely be a bug, since we want
> to return gracefully with *something*.
>
> Just a heads up. Review Board 1.5 RC 1 is out, and we're looking to release
> hopefully soon (just working on docs and some last-minute bugs). There's a
> new API in 1.5 that sits alongside the old API. The new one is better,
> cleaner, more flexible, and will let you do more of what you need. I don't
> know how you want to handle development of this plugin, but if you want to
> support 1.5's API as well, you can query /api/info/, and if that's not a
> 404, it will be 1.5.
>
> Christian
>
> --
> Christian Hammond - chip...@chipx86.com
> Review Board - http://www.reviewboard.org
> VMware, Inc. - http://www.vmware.com
>
>
> On Thu, Jul 15, 2010 at 12:51 PM, Aleix Pol <aleix...@gmail.com> wrote:
>
>> Hi,
>> I am Aleix Pol, from the KDE project. I'm working on a little plugin
>> for KDevelop that will enable the user to send patches directly a
>> reviewboard service.
>>
>> I've been testing the API using curl and there I can create a new
>> review but when I try to add a patch I get an HTML error saying that
>> "review board is taking a nap", which is weird not only because I
>> didn't know that software took naps but because the rest of the API
>> replies with JSON data but here it's that weird HTML error message.
>>
>> Could somebody tell my why is that happening?
>>
>> I am using that line:
>> curl http://reviewboard.kde.org/api/json/reviewrequests/4647/diff/new -
>> u apol -X POST --data "" -T test_reviewboard.patch
>>
>> Thanks,
>> Aleix
>>
>> PS: The service should be working because it works with postreview.
>>
>> --
>> Want to help the Review Board project? Donate today at
>> http://www.reviewboard.org/donate/
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> -~----------~----~----~----~------~----~------~--~---
>> To unsubscribe from this group, send email to
>> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
>> For more options, visit this group at
>> http://groups.google.com/group/reviewboard?hl=en
>
>
>  --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to