As far as I can tell, I have all the dependencies installed, except
I'm getting this error (error modified to exclude actual server

mod_python (pid=431, interpreter='reviewboard_foo_example_com',
phase='PythonHandler', handler='django.core.handlers.modpython'):
Application error
ServerName: ''
DocumentRoot: '/var/www/'
URI: '/subject/'
Location: '/subject/'
Directory: None
Filename: '/var/www/'
PathInfo: '/'
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/mod_python/",
line 1537, in HandlerDispatch\n    default=default_handler, arg=req,
  File "/usr/lib64/python2.6/site-packages/mod_python/",
line 1229, in _process_target\n    result = _execute_target(config,
req, object, arg)
  File "/usr/lib64/python2.6/site-packages/mod_python/",
line 1128, in _execute_target\n    result = object(arg)
  File "/usr/lib64/python2.6/site-packages/django/core/handlers/", line 228, in handler\n    return ModPythonHandler()
  File "/usr/lib64/python2.6/site-packages/django/core/handlers/", line 191, in __call__\n    self.load_middleware()
  File "/usr/lib64/python2.6/site-packages/django/core/handlers/", line 42, in load_middleware\n    raise
exceptions.ImproperlyConfigured, 'Error importing middleware %s: "%s"'
% (mw_module, e)
ImproperlyConfigured: Error importing middleware
reviewboard.admin.middleware: "No module named encoders"

I'm stumped.  From the reviewboard code, it looks like the only
"encoders" used comes from djblets, and that's in my site-packages

What can I do to diagnose this problem further, or fix it?

Any help appreciated.

Want to help the Review Board project? Donate today at
Happy user? Let us know at
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to