That setting needs to be set in your site's conf/settings_local.py, and the
web server restarted. If you modified global_settings.py, you should
probably change it back.

If that still doesn't work, let me know, and we'll dig deeper.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Mon, Jun 20, 2011 at 3:14 PM, rfs <rfs...@gmail.com> wrote:

> I'm running ReviewBoard 1.5.5 and recently discovered that the
> "Recover Password" feature is not working.  After entering the email
> address and submitting the form, I get "Something Broke! (Error
> 500)".  Looking at the apache error log shows:
>
> ERROR:root:Exception thrown for user AnonymousUser at
> http://reviewboard.rossvideo.com/account/recover/
>
> (504, 'Need Fully Qualified Address', u'webmaster@localhost')
> Traceback (most recent call last):
>  File "/usr/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/
> core/handlers/base.py", line 100, in get_response
>    response = callback(request, *callback_args, **callback_kwargs)
>  File "/usr/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/
> utils/decorators.py", line 76, in _wrapped_view
>    response = view_func(request, *args, **kwargs)
>  File "/usr/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/
> contrib/auth/views.py", line 123, in password_reset
>    form.save(**opts)
>  File "/usr/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/
> contrib/auth/forms.py", line 143, in save
>    t.render(Context(c)), None, [user.email])
>  File "/usr/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/
> core/mail/__init__.py", line 61, in send_mail
>    connection=connection).send()
>  File "/usr/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/
> core/mail/message.py", line 175, in send
>    return self.get_connection(fail_silently).send_messages([self])
>  File "/usr/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/
> core/mail/backends/smtp.py", line 85, in send_messages
>    sent = self._send(message)
>  File "/usr/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/
> core/mail/backends/smtp.py", line 101, in _send
>    email_message.message().as_string())
>  File "/usr/lib64/python2.6/smtplib.py", line 698, in sendmail
>    raise SMTPSenderRefused(code, resp, from_addr)
> SMTPSenderRefused: (504, 'Need Fully Qualified Address',
> u'webmaster@localhost')
>
>
> Reviewboard is able to send mail normally (eg. when reviews are
> posted), so it is not the mail server configuration.  It looks like
> the webmaster@localhost is the problem.  I tried to solve this,
> chasing it back down to DEFAULT_FROM_EMAIL in global_settings.py.
>
> However making changes to that file (and rebuilding the .pyc files)
> does not seem to change the error... Reviewboard continues to use
> webmaster@localhost
>
> Any suggestions would be appreciated!
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to