I should add that this is with ReviewBoard 1.5.5

On Aug 23, 8:15 am, Zamir Khan <zamir.k...@gmail.com> wrote:
> Hi all,
>
> I'm a second-time review-board user, having successfully set it up at
> a previous place of employment. I liked it so much, I decided to give
> it another go at my new position. However, this second time I've run
> into more installation problems than the first, likely because I have
> less control over the environment.
>
> I am running reviewboard on a Windows VM with MySQL, Apache 2.2,
> Python 2.5.4, etc. (let me know what else you need to know)
>
> We have a Perforce repository, however it does not sit on our local
> network. It is located in another office across the country, but we
> access it through a bridge to that network (not sure if that's the
> right term, essentially our LANs are connected somehow). So I access
> perforce through a URL and port as usual.
>
> I've run into problems throughout the setup, but eventually gotten
> past each one, only to be stuck setting up post-review. Currently,
> when I run post-review, I get the following error message:
>
> C:\>post-review -d>>> RBTools 0.3.3
> >>> Home = C:\Users\code-review\AppData\Roaming
> >>> p4 info
> >>> repository info: Path: Softdev.*******.local:65100, Base path: None, 
> >>> Suppor
> s changesets: True
> >>> p4 counters
> >>> HTTP GETting api/
>
> Traceback (most recent call last):
>   File "C:\Python25\Scripts\post-review-script.py", line 8, in
> <module>
>     load_entry_point('rbtools==0.3.3', 'console_scripts', 'post-
> review')()
>   File "build/bdist.linux-x86_64/egg/rbtools/postreview.py", line
> 3952, in main
>   File "build/bdist.linux-x86_64/egg/rbtools/postreview.py", line 510,
> in check
> api_version
>   File "build/bdist.linux-x86_64/egg/rbtools/postreview.py", line 959,
> in api_g
> t
>   File "build/bdist.linux-x86_64/egg/rbtools/postreview.py", line 929,
> in http_
> et
>   File "C:\Python25\lib\urllib2.py", line 124, in urlopen
>     return _opener.open(url, data)
>   File "C:\Python25\lib\urllib2.py", line 381, in open
>     response = self._open(req, data)
>   File "C:\Python25\lib\urllib2.py", line 399, in _open
>     '_open', req)
>   File "C:\Python25\lib\urllib2.py", line 360, in _call_chain
>     result = func(*args)
>   File "C:\Python25\lib\urllib2.py", line 1107, in http_open
>     return self.do_open(httplib.HTTPConnection, req)
>   File "C:\Python25\lib\urllib2.py", line 1082, in do_open
>     raise URLError(err)
> urllib2.URLError: <urlopen error (11004, 'getaddrinfo failed')>
>
> Strangely enough, I get this message no matter what URL I set through
> p4 counter - whether it is valid or not.
>
> Any ideas?
>
> Thanks in advance.

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to