I'm trying to set up LDAP authentication for our RB 1.6.2 site, however
after trying several different combinations of settings I still get the
same error every time:

                   WARNING:root:LDAP error: The specified object does not
exist in the Directory or provided invalid credentials: CN=<username>

I have the server going to the correct IP and port, I've set up LDAP in
several other places and so I know the LDAP Base DN is correct, I used
JXplorer to log into the LDAP server itself and pull the field names for
Given Name/Surname/Full Name, the e-mail domain is set to '@mycompany.com',
but I also pulled the field name for E-mail LDAP Attribute from JXplorer.

We use a bind account to connect to our LDAP, and I figured out that the
'Anonymous User Mask/Password' is meant for this account. Something to note
-- when I put the full path to the user in the Anon. User Mask field -- IE
CN=<bind user>,OU=People,DC=dir,DC=svc,DC=<company>,DC=com, it can't bind.
I have to strip it down to just CN=<bind user> before it'll connect
properly. With that knowledge, I've tried setting User Mask to both the
full CN=%s,OU=People,DC=etc etc and just setting CN=%s. In both cases I
still get the above error, even though I know my username and password are
correct. I've had several others also try to log in, with no success. Has
anyone else had this error? Any tips?

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to