Since upgrading to 1.7.1 all new reviews have been running into this issue 
(backtrace below).

I did some digging into the traceback that was generated and found the 

reviewboard/scmtools/ line 215, the "version" variable being passed to 
parse_version is None.
This is coming from line 213 "from mercurial.__version__ import version"

When I run the line above from the command line I get back "1.9", but for 
some reason it is not working from the web server.

I have not changed any set up with the web server since upgrading from 
1.6.13 to 1.7.1, but this wasn't an issue before.

I have verified the rb-site was properly upgraded.

Is there something I missed somewhere? To get it to work in the mean time I 
hardcoded the version number for mercurial, which seems to have mitigated 
the issue (and made me feel really dirty), but I'm still not sure why it 
thinks it should break itself.

Traceback (most recent call last):

line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

line 20, in _check
    return login_required(view_func)(*args, **kwargs)

line 47, in _checklogin
    return view_func(request, *args, **kwargs)

line 728, in review_detail
    'screenshots': screenshots,

line 124, in _make_review_request_context
    upload_diff_form = UploadDiffForm(review_request)

line 276, in __init__
    data, *args, **kwargs)

line 51, in __init__
    if self.repository.get_scmtool().get_diffs_use_absolute_paths():

line 134, in get_scmtool
    return cls(self)

line 31, in __init__
    self.client = HgClient(repository.path, repository.local_site)

line 215, in __init__
    if parse_version(version) <= parse_version("1.2"):

line 1984, in parse_version
    for part in _parse_version_parts(s.lower()):

TypeError: 'NoneType' object is not callable

Want to help the Review Board project? Donate today at
Happy user? Let us know at
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to