I can get the reviewboard web interface to see my p4 repository (and it 
the change descriptions if I try to create a a new review request.)

I'm seeing:

Traceback (most recent call last):
  File "/usr/local/bin/rbt", line 8, in <module>
    load_entry_point('RBTools==0.6', 'console_scripts', 'rbt')()
line 134, in main
    command.run_from_argv([RB_MAIN, command_name] + args)
line 422, in run_from_argv
    exit_code = self.main(*args) or 0
line 12, in main
line 356, in print_clients
    repository_info = tool.get_repository_info()
line 183, in get_repository_info
    p4_info = self.p4.info()
line 73, in info
line 101, in run_p4
    if self.options.p4_client:
AttributeError: 'Namespace' object has no attribute 'p4_client'

from rbt list-repo-types.

I don't have permission to make counters (which seems to be a suggested 
work around for getting rbt post to work.)

rbt diff -d <change number that worked in the web interface>
rbt post -d <change number that worked in the web interface>


ERROR: The current directory does not contain a checkout from a supported 
source code repository.

I know the old p4 server means I don't have the shelve option.  We are 
currently pushing changes
to a development branch then merging that into a release branch.   Is there 
some trick I'm missing
for getting the rbt to build a diff for an already submitted p4 change?

      Dan S.

Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
Happy user? Let us know at http://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to