Hi Sara,

David has a repro case for this now, so we're looking into a fix.

There will be a 2.0.8 release tonight.

Christian

-- 
Christian Hammond - christ...@beanbaginc.com
Review Board - https://www.reviewboard.org 
Beanbag, Inc. - https://www.beanbaginc.com


On September 23, 2014 at 3:17:04 PM, Christian Hammond 
(christ...@beanbaginc.com) wrote:
> Hi Sara,
> 
> Something that would really help is a complete dump of the request/responses 
> (headers 
> and payloads) for any requests to /api/* in the Network tab of Firefox when 
> these issues 
> occur.
> 
> I know some information was sent before, but those look to be the Console tab 
> only.
> 
> Christian
> 
> --
> Christian Hammond - christ...@beanbaginc.com
> Review Board - https://www.reviewboard.org
> Beanbag, Inc. - https://www.beanbaginc.com
> 
> 
> On September 23, 2014 at 2:23:34 PM, Christian Hammond 
> (christ...@beanbaginc.com) 
> wrote:
> > I wish I knew too...
> >
> > So, for each of these cases, is the only visible error the "rsp is null" 
> > error?
> >
> > This is tricky to diagnose without more direct access to the server. Hoping 
> > something 
> > will allow me to repro it here.
> >
> > Christian
> >
> > --
> > Christian Hammond - christ...@beanbaginc.com
> > Review Board - https://www.reviewboard.org
> > Beanbag, Inc. - https://www.beanbaginc.com
> >
> >
> > On September 23, 2014 at 1:43:11 PM, Sara Rayburn (sararayb...@gmail.com) 
> > wrote: 
> > > I wish I knew what this was. We've had three developers run into this bug
> > > today alone. It's becoming a real problem for us. More answers to your
> > > questions inline below.
> > > Sara
> > >
> > > On Tuesday, September 23, 2014 2:08:28 PM UTC-5, Christian Hammond wrote:
> > > >
> > > > Hi Sara,
> > > >
> > > >
> > > > On September 23, 2014 at 11:39:53 AM, Sara Rayburn (sarar...@gmail.com
> > > > ) wrote:
> > > > > On Tuesday, September 23, 2014 1:11:18 PM UTC-5, Christian Hammond
> > > > wrote:
> > > > > >
> > > > > > Hi Sara,
> > > > > >
> > > > > > There are several things here that I am very confused about:
> > > > > >
> > > > > > 1) Can you clarify which part is new since 2.0.7? The subject says
> > > > 2.0.6.
> > > > > >
> > > > >
> > > > > That is weird. I wasn't the original poster. We have only seen the bug
> > > > > since updating to 2.0.7. I know this because we have a request with
> > > > > non-unicode contents that was uploaded before I updated, without
> > > > problems.
> > > > > Trying to reuse the same patch for an additional review request
> > > > triggered
> > > > > the same unicode error we saw previously.
> > > >
> > > > On September 9th, you posted saying "I am having a similar problem after
> > > > upgrading to 2.0.6." We didn't have a 2.0.7 release until the 15th.
> > > >
> > > >
> > > > Good point. I guess it's a problem since before that.
> > >
> > > >
> > > > > > 1) Is this still only happening with Firefox?
> > > > > >
> > > > > Yes
> > > > >
> > > > > >
> > > > > > 2) What version of Firefox?
> > > > > >
> > > > > > 30
> > > >
> > > > Does 33 work? I haven't had any issues with any recent version...
> > > >
> > > >
> > > > Tried in most recent Firefox (35), issue remains.
> > >
> > >
> > > > > > 4) If MySQL, are the tables set for Unicode?
> > > > > >
> > > > > > The tables are a mix of latin1 and utf8. Perhaps this is the 
> > > > > > problem?
> > > >
> > > > This is likely to be the cause of at least some of your problems. You'll
> > > > need to make sure they're all in utf8, otherwise there will be issues 
> > > > even
> > > > populating the database with non-latin1 text. This can break us in 
> > > > numerous
> > > > ways.
> > > >
> > > > I made sure the database encodings were utf8 and even set the encoding 
> > > > for
> > > the repository in question to utf8 in the admin repo settings for
> > > reviewboard. I added utf8 as the charset in settings_local.py. All of 
> > > these
> > > changes later, I still have the problem.
> > >
> > > >
> > > > > > 5) Are you using any form of proxy server at your company?
> > > > > >
> > > > > > No. Very vanilla setup on a VM.
> > > >
> > > > How about HTTP proxies that the users configure in their browsers? We've
> > > > seen cases in the past of some proxies messing with the responses from 
> > > > our
> > > > API.
> > > >
> > > > Nope, no one.
> > >
> > > > Christian
> > > >
> > > >
> > > > --
> > > > Christian Hammond - chri...@beanbaginc.com
> > > > Review Board - https://www.reviewboard.org
> > > > Beanbag, Inc. - https://www.beanbaginc.com
> > > >
> > > >
> > > > >
> > > > >
> > > > >
> > > > > > Thanks,
> > > > > >
> > > > > > Christian
> > > > > >
> > > > > > --
> > > > > > Christian Hammond - chri...@beanbaginc.com
> > > > > > Review Board - https://www.reviewboard.org
> > > > > > Beanbag, Inc. - https://www.beanbaginc.com
> > > > > >
> > > > > >
> > > > > > On September 23, 2014 at 10:57:14 AM, Sara Rayburn 
> > > > > > (sarar...@gmail.com
> > > > > > ) wrote:
> > > > > > > I can also confirm that this is a new bug since 2.0.7. One of the
> > > > review
> > > > > > > requests giving us trouble was added before we updated, and when
> > > > someone
> > > > > > > tried to change the submitter on the request it seems to have run
> > > > into
> > > > > > the
> > > > > > > error again. When the same user copied the patch and created a new
> > > > > > review
> > > > > > > request (since they couldn't take ownership of the request) they 
> > > > > > > ran
> > > > > > into
> > > > > > > the unicode bug again.
> > > > > > >
> > > > > > > On Tuesday, September 23, 2014 12:51:51 PM UTC-5, Sara Rayburn
> > > > wrote:
> > > > > > > >
> > > > > > > > Any new information on this bug? We've run into it several 
> > > > > > > > times.
> > > > > > > >
> > > > > > > > On Thursday, August 28, 2014 8:09:02 AM UTC-5, 
> > > > > > > > koval...@gmail.com
> > > > > > wrote:
> > > > > > > >>
> > > > > > > >> I am using Reviewboard 2.0.6 with Postgres database in utf-8.
> > > > > > > >> When I making new pre-commit request on svn-based repository 
> > > > > > > >> with
> > > > > > > >> diff-file containing non-latin symbols, reviewboard hungs.
> > > > > > > >> If diff file contains only latin symbols, it works ok.
> > > > > > > >>
> > > > > > > >> Is it possible to fix this bug?
> > > > > > > >>
> > > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > Get the Review Board Power Pack at
> > > > http://www.reviewboard.org/powerpack/
> > > > > > > ---
> > > > > > > Sign up for Review Board hosting at RBCommons:
> > > > https://rbcommons.com/
> > > > > > > ---
> > > > > > > Happy user? Let us know at http://www.reviewboard.org/users/
> > > > > > > ---
> > > > > > > You received this message because you are subscribed to the Google
> > > > > > Groups "reviewboard"
> > > > > > > group.
> > > > > > > To unsubscribe from this group and stop receiving emails from it,
> > > > send
> > > > > > an email to reviewboard...@googlegroups.com .
> > > > > > > For more options, visit https://groups.google.com/d/optout.
> > > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > > --
> > > > > Get the Review Board Power Pack at 
> > > > > http://www.reviewboard.org/powerpack/
> > > > > ---
> > > > > Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
> > > > > ---
> > > > > Happy user? Let us know at http://www.reviewboard.org/users/
> > > > > ---
> > > > > You received this message because you are subscribed to the Google
> > > > Groups "reviewboard"
> > > > > group.
> > > > > To unsubscribe from this group and stop receiving emails from it, send
> > > > an email to reviewboard...@googlegroups.com .
> > > > > For more options, visit https://groups.google.com/d/optout.
> > > > >
> > > >
> > > >
> >
> >
> 
> 

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to