Thanks for the info! I really appreciate the detailed analysis.

It's possible that Firefox is sending some bad mimetype data that's messing
things up. We'll take a look at this, see if we can also reproduce it.

Christian

-- 
Christian Hammond - christ...@beanbaginc.com
Review Board - https://www.reviewboard.org
Beanbag, Inc. - https://www.beanbaginc.com

On Thu, Jul 2, 2015 at 1:01 PM, Melroy van den Berg <webmaster1...@gmail.com
> wrote:

> Hi Christian,
>
> After some debugging, try & error. I found out the following:
>
>    - Uploading PDF works under Windows using Firefox webbrowser, after it
>    is uploaded will render a thumbnail, so you can use the Document Review
>    tool of this Power Pack.
>    - Uploading & review also works under Linux using Chrome, again a
>    thumbnail appears
>    - However, uploading does work, but it won't start generating a
>    thumbnail at all under *Firefox* under Linux (*Linux Mint*). I'm using
>    Firefox 38, I guess one of the latest versions.
>    I also restarted Firefox with the 'All add-ons disabled' feature,
>    still without luck.
>
> Conclusion: Firefox under Linux + Power Pack doesn't work as expected. I
> can't use upload feature to upload a PDF for review under Firefox Linux.
>
>
> I also tried to debug using the build-in console, there is no Javascript
> error so far. It just seems the javascript just stops, instead of reading
> the PDF file and try to create a TOC and thumbnail for the review.
>
>
> I hope you can help me further.
>
>
> Kind regards,
>
> Melroy van den Berg
>
>
>
>
> Op maandag 29 juni 2015 21:54:52 UTC+2 schreef Christian Hammond:
>>
>> "Allow code profiling" doesn't by itself log any additional information.
>> It's used to help diagnose things along with other arguments.
>>
>> Can you try reloading your web server, then shift-reload the review
>> request page again?
>>
>> Christian
>>
>> --
>> Christian Hammond - chri...@beanbaginc.com
>> Review Board - http://www.reviewboard.org
>> Beanbag, Inc. - http://www.beanbaginc.com
>>
>> On Mon, Jun 29, 2015 at 12:36 PM, Melroy van den Berg <
>> webmas...@gmail.com> wrote:
>>
>>> Futhermore, "Allow code profiling" doesn't help me either.
>>>
>>> Op maandag 29 juni 2015 21:31:23 UTC+2 schreef Melroy van den Berg:
>>>
>>>>  The only line I got after enabling logging in debug is:
>>>>
>>>> 2015-06-29 19:25:53,085 - INFO -  - Reloading logging settings
>>>>>
>>>>
>>>> That is strange right? After uploading a new document (PDF)? I would
>>>> like to see more debug info... Well, no errors at this for sure.
>>>>
>>>>  --
>>> Supercharge your Review Board with Power Pack:
>>> https://www.reviewboard.org/powerpack/
>>> Want us to host Review Board for you? Check out RBCommons:
>>> https://rbcommons.com/
>>> Happy user? Let us know! https://www.reviewboard.org/users/
>>> ---
>>> You received this message because you are subscribed to the Google
>>> Groups "reviewboard" group.
>>> To unsubscribe from this group and stop receiving emails from it, send
>>> an email to reviewboard...@googlegroups.com.
>>> For more options, visit https://groups.google.com/d/optout.
>>>
>>
>>

-- 
Supercharge your Review Board with Power Pack: 
https://www.reviewboard.org/powerpack/
Want us to host Review Board for you? Check out RBCommons: 
https://rbcommons.com/
Happy user? Let us know! https://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to