Did you fix this problem ?  I also meet it .

My set :
RBTools 0.7.4

reviewboard 2.0.6

svn :1.8.0


>>> Making HTTP GET request to 
http://123.56.88.207:1080/api/repositories/4/info/
>>> Got API Error 210 (HTTP code 500): There was an error fetching extended 
information for this repository
>>> Error data: {u'stat': u'fail', u'err': {u'msg': u'There was an error 
fetching extended information for this repository', u'code': 210}}
>>> Running: svn --non-interactive info
>>> Running: diff --version
>>> Running: svn --non-interactive --version -q
>>> repository info: Path: svn://svn.trusdom.com, Base path: 
/branches/pinclub_20151104


在 2014年6月30日星期一 UTC+8下午6:17:48,Stephen写道:
>
>
> I'm trying to setup a new ReviewBoard 2.0.2 instance with a Perforce SCM 
> server. The RB site can be accessed via the browser fine but I'm having 
> trouble posting my first review. I get this error when I run rbt post:
>
> >>> Making HTTP GET request to 
> http://srv-team-web2/rbsite2/api/repositories/
> >>> Making HTTP GET request to 
> http://srv-team-web2/rbsite2/api/review-requests/
> >>> Making HTTP POST request to 
> http://srv-team-web/rbsite2/api/review-requests/
> >>> Got API Error 210 (HTTP code 500): There was an error fetching 
> extended information for this repository.
> >>> Error data: {u'stat': u'fail', u'err': {u'msg': u'There was an error 
> fetching extended information for this repository.', u'code': 210}}
> Traceback (most recent call last):
>   File "/usr/local/bin/rbt", line 9, in <module>
>     load_entry_point('RBTools==0.6.1', 'console_scripts', 'rbt')()
>   File 
> "/usr/local/lib/python2.7/dist-packages/RBTools-0.6.1-py2.7.egg/rbtools/commands/main.py",
>  
> line 134, in main
>     command.run_from_argv([RB_MAIN, command_name] + args)
>   File 
> "/usr/local/lib/python2.7/dist-packages/RBTools-0.6.1-py2.7.egg/rbtools/commands/__init__.py",
>  
> line 416, in run_from_argv
>     exit_code = self.main(*args) or 0
>   File 
> "/usr/local/lib/python2.7/dist-packages/RBTools-0.6.1-py2.7.egg/rbtools/commands/post.py",
>  
> line 784, in main
>     submit_as=self.options.submit_as)
>   File 
> "/usr/local/lib/python2.7/dist-packages/RBTools-0.6.1-py2.7.egg/rbtools/commands/post.py",
>  
> line 507, in post_request
>     raise CommandError("Error creating review request: %s" % e)
> rbtools.commands.CommandError: Error creating review request: There was an 
> error fetching extended information for this repository. (HTTP 500, API 
> Error 210)
>
> The RB Server log shows an authentication error but I am able to log onto 
> the Perforce server using the same credentials from the command line as the 
> user concerned from the server host. The error is:
>
> 2014-06-30 10:09:25,132 - ERROR - None - stephen - 
> /rbsite2/api/review-requests/ - Got unexpected SCMError when creating 
> repository: [P4#run] Errors during command execution( "p4 login" )
>
>     [Error]: "Password invalid.\n'ADAuthentication' validation failed: 
> Authentication Failed. Access Denied"
>
> Traceback (most recent call last):
>   File 
> "/usr/local/lib/python2.7/dist-packages/ReviewBoard-2.0.2-py2.7.egg/reviewboard/webapi/resources/review_request.py",
>  
> line 564, in create
>     create_from_commit_id=create_from_commit_id)
>   File 
> "/usr/local/lib/python2.7/dist-packages/ReviewBoard-2.0.2-py2.7.egg/reviewboard/reviews/managers.py",
>  
> line 135, in create
>     review_request.update_from_commit_id(commit_id)
>   File 
> "/usr/local/lib/python2.7/dist-packages/ReviewBoard-2.0.2-py2.7.egg/reviewboard/reviews/models/base_review_request_details.py",
>  
> line 181, in update_from_commit_id
>     changeset = scmtool.get_changeset(commit_id, allow_empty=True)
>   File 
> "/usr/local/lib/python2.7/dist-packages/ReviewBoard-2.0.2-py2.7.egg/reviewboard/scmtools/perforce.py",
>  
> line 327, in get_changeset
>     changeset = self.client.get_changeset(changesetid)
>   File 
> "/usr/local/lib/python2.7/dist-packages/ReviewBoard-2.0.2-py2.7.egg/reviewboard/scmtools/perforce.py",
>  
> line 203, in get_changeset
>     return self._run_worker(lambda: self._get_changeset(changesetid))
>   File 
> "/usr/local/lib/python2.7/dist-packages/ReviewBoard-2.0.2-py2.7.egg/reviewboard/scmtools/perforce.py",
>  
> line 189, in _run_worker
>     self._convert_p4exception_to_scmexception(e)
>   File 
> "/usr/local/lib/python2.7/dist-packages/ReviewBoard-2.0.2-py2.7.egg/reviewboard/scmtools/perforce.py",
>  
> line 176, in _convert_p4exception_to_scmexception
>     raise SCMError(error)
> SCMError: [P4#run] Errors during command execution( "p4 login" )
>
>     [Error]: "Password invalid.\n'ADAuthentication' validation failed: 
> Authentication Failed. Access Denied"
>
> Is there any extra logging I can enable to investigate a Perforce SCM 
> repository setup?
>
> Note: I've had no trouble using the same Perforce server with a RB 1.6 
> server I setup.
>
> Thanks,
> Stephen.
>
>

-- 
Supercharge your Review Board with Power Pack: 
https://www.reviewboard.org/powerpack/
Want us to host Review Board for you? Check out RBCommons: 
https://rbcommons.com/
Happy user? Let us know! https://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to