Quick update, managed to get subvertpy installed and Review Board seems to 
be detecting it correctly as well. The missing package was subversion-devel 
so the following command fixed my issue.
sudo yum install subversion-devel

Now I'm on to a new issue of Review Board either throwing a 500 error when 
I try to add a repo or saying that the repo is not found at the specified 
path. I'll save that for another post since it would be off topic here :)

On Friday, January 22, 2016 at 11:47:53 AM UTC-5, Mike Baker wrote:
> Hi all,
> I've managed to get through most of the Review Board install process 
> successfully except for the installation of subvertpy. It seems the 
> installation of subvertpy is looking for a number of environment variables 
> that aren't currently present on my server.
> To give you some context, I'm medium familiar with unix systems to the 
> extent that installing packages, configuring Apache, etc are all pretty 
> straightforward but the process of figuring out which packages would set 
> specific environment variables is a bit out of my depth. The system I'm 
> working with is an Amazon EC2 t2.micro instance based of the Amazon Linux 
> AMI 2015.09.1 (HVM) (ami-60b6c60a).
> Initially, I tried to install through the yum package manager but Review 
> Board complained that it couldn't find subvertpy when I tried to add a 
> repo. Based on the notes in the Review Board 2.0.2 release (
> https://www.reviewboard.org/docs/releasenotes/reviewboard/2.0.2/) it 
> looks like subvertpy needs to be newer than 0.9.1 to work and the package 
> manager only has up to subvertpy v0.8.1.
> So I resorted to using pip or easy_install to get subvertpy up and 
> running. At first, the installation failed because the environment variable 
> $APR_CONFIG couldn't be found. After a bunch of Googling I ran the 
> following command to install the required packages:
> sudo yum -y install arp apr-devel apr-util apr-util-devel pcre pcre-devel
> This fixed the missing environment variable but now we're onto a new one.
> Complete output from command python setup.py egg_info:
>     Traceback (most recent call last):
>       File "<string>", line 1, in <module>
>       File "/tmp/pip-build-me3oaT/subvertpy/setup.py", line 251, in 
> <module>
>         (svn_includedirs, svn_libdirs, svn_link_flags, extra_libs) = 
> svn_build_data()
>       File "/tmp/pip-build-me3oaT/subvertpy/setup.py", line 113, in 
> svn_build_data
>         raise Exception("Subversion development files not found. "
>     Exception: Subversion development files not found. Please set 
> SVN_PREFIX or (SVN_LIBRARY_PATH and SVN_HEADER_PATH) environment variable.
>     ----------------------------------------
> Command "python setup.py egg_info" failed with error code 1 in 
> /tmp/pip-build-me3oaT/subvertpy
> I'm going to start hunting down the required packages for these 
> environment variables but I can't help but think there's an easier way. Can 
> someone either help me understand how to better resolve the dependencies or 
> give me a list of packages that subvertpy assumes are setup in the 
> environment?
> Thanks

Supercharge your Review Board with Power Pack: 
Want us to host Review Board for you? Check out RBCommons: 
Happy user? Let us know! https://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to