I'm running into an issue where I can't add repositories to Review Board 
and have tried many of the different suggestions from other posts to no 
avail. Anybody have any suggestions or ideas?


   - Amazon EC2 t2.micro instance based of the Amazon Linux AMI 2015.09.1 
   (HVM) (ami-60b6c60a)
   - Review Board v2.5.2
   - Subvertpy v0.9.2
   - Apache v2.2.31 (with mod_dav_svn installed)
   - Subversion v1.8.13
   - Python v2.7.10
   - Repositories aren't accessible through http and port 80. They can only 
   be accessed through https and port 443
   - Tested with both a valid and invalid SSL certificate
   - Review Board is currently only accessible through an https connection 
   with a self signed certificate. This shouldn't be an issue. Aside from the 
   browser warning on first visit and the issue being described the rest of 
   Review Board seems to work fine.
   - Both username and password in SVN credentials are alphanumeric
   - Repo name has an _ in it. Probably doesn't matter...
   - With Review Board logging enabled reports the following error:
   2016-01-22 23:37:10,852 - INFO -  - Reloading logging settings
   2016-01-22 23:37:52,641 - ERROR -  - SVN: Failed to get repository 
   information for https://svn.mycompany.com/reponame/: ("Unable to connect 
   to a repository at URL 'https://svn.mycompany.com/reponame'", 215004)
   - I did previously have an issue installing subvertpy documented 
   here: https://groups.google.com/forum/#!topic/reviewboard/Z5TvuhP1EIQ I did 
   manage to get it installed although there were a bunch of warnings about 
   deprecated references while it was installing.

*Things I've Tried*

   - Running the following command. After entering the password and 
   accepting the certificate the command was able to successfully retrieve the 
   repo's information
   svn list --username mbaker https://svn.mycompany.com/reponame/
   - Copying the ~/.subversion/auth/ folder into the /{path to 
   reviewboard}/data/.subversion/auth/ folder and changing ownership to the 
   group and user apache runs on.
      - I should note that this fixed another issue I was having where one 
      of my repos had an invalid certificate and Review Board would throw a 500 
      server error when trying to confirm that Review Board should accept it. I 
      can include the error stack logged when this was happening if it's useful 
      but this seems unrelated to my current issue.
   - Entering the http version of the URL in the Path field and the https 
   url in the mirror path field
   - Tried with SVN credentials that have both read-only permissions on 
   repo as well as read/write
   - Trying another SVN repo on a different server resulted in the same 
   problem. All of the approaches listed above were also attempted against 
   this other server/repo.

Any ideas or help would be greatly appreciated. Pretty much out of ideas at 
this point but I'll keep trying different approaches and pouring through 
configs and logs this weekend.


Supercharge your Review Board with Power Pack: 
Want us to host Review Board for you? Check out RBCommons: 
Happy user? Let us know! https://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to