Todd Lipcon has posted comments on this change.

Change subject: consensus: split ReplicaState in twain[1]
......................................................................


Patch Set 1:

(2 comments)

http://gerrit.cloudera.org:8080/#/c/4713/1/src/kudu/consensus/raft_consensus_state.h
File src/kudu/consensus/raft_consensus_state.h:

Line 71: class ReplicaState {
> should we rename this to ConsensusMetaState or something?
yea, wanted to defer that to another patch where we clean up the remainder of 
this class. In fact most of what remains is some locking and a bunch of 
"pass-through" methods to ConsensusMeta, so maybe this class isn't really 
necessary at all.

I guess I should update the class doc though.


Line 257: // Tracks the pending consensus rounds being managed by a Raft 
replica (either leader
> not your fault, but the mix of rounds, ops and transactions in method names
yea, I left a TODO below about this but let me move the TODO up to the top here 
about cleaning up naming throughout. I tried to minimize renames in this patch 
just to keep it easy to review.


-- 
To view, visit http://gerrit.cloudera.org:8080/4713
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I95308ae8a5d65ada016ae08e0e8cf06c54b35909
Gerrit-PatchSet: 1
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Todd Lipcon <t...@apache.org>
Gerrit-Reviewer: David Ribeiro Alves <dral...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Mike Percy <mpe...@apache.org>
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon <t...@apache.org>
Gerrit-HasComments: Yes

Reply via email to