> On May 21, 2015, 10:47 p.m., Joris Van Remoortere wrote:
> > Hi Mark,
> > Can you fold in the operators that are added in: 
> > https://reviews.apache.org/r/34518 please?
> > Thanks!

No problem. Do we need to inline here? If we do, Don't we need to add to every 
operators for consistency?


> On May 21, 2015, 10:47 p.m., Joris Van Remoortere wrote:
> > 3rdparty/libprocess/3rdparty/stout/tests/option_tests.cpp, line 93
> > <https://reviews.apache.org/r/34529/diff/1/?file=966107#file966107line93>
> >
> >     2 new lines (add 1 more).
> >     Same below.

ok


> On May 21, 2015, 10:47 p.m., Joris Van Remoortere wrote:
> > 3rdparty/libprocess/3rdparty/stout/tests/option_tests.cpp, line 94
> > <https://reviews.apache.org/r/34529/diff/1/?file=966107#file966107line94>
> >
> >     Can we have a more meaningful name for this class?

removed the class.


> On May 21, 2015, 10:47 p.m., Joris Van Remoortere wrote:
> > 3rdparty/libprocess/3rdparty/stout/tests/option_tests.cpp, line 101
> > <https://reviews.apache.org/r/34529/diff/1/?file=966107#file966107line101>
> >
> >     Let's use the full name `Reference`

ok


> On May 21, 2015, 10:47 p.m., Joris Van Remoortere wrote:
> > 3rdparty/libprocess/3rdparty/stout/tests/option_tests.cpp, lines 103-111
> > <https://reviews.apache.org/r/34529/diff/1/?file=966107#file966107line103>
> >
> >     let's use full or more meaningful names for these variables.

ok


- Mark


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/34529/#review84808
-----------------------------------------------------------


On May 21, 2015, 10:36 p.m., Mark Wang wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/34529/
> -----------------------------------------------------------
> 
> (Updated May 21, 2015, 10:36 p.m.)
> 
> 
> Review request for mesos and Joris Van Remoortere.
> 
> 
> Bugs: MESOS-2716
>     https://issues.apache.org/jira/browse/MESOS-2716
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Add non-const reference version of Option<T>::get.
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/3rdparty/stout/include/stout/option.hpp 
> ea79b501d9ed7b7da9636ce9c9c590738a586993 
>   3rdparty/libprocess/3rdparty/stout/tests/option_tests.cpp 
> 7ae3b8ffc5df7f8442e72b1a10d50c3f5c373d8c 
> 
> Diff: https://reviews.apache.org/r/34529/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Mark Wang
> 
>

Reply via email to