-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/35717/#review89538
-----------------------------------------------------------


I made a minor naming comment, which I'll get cleaned up for you.

Is there a plan to consistently add reserved and unreserved to the other 
resources? e.g. used and offered.
Curious if you thought about how to express volumes as well?


src/common/http.cpp (line 84)
<https://reviews.apache.org/r/35717/#comment142161>

    How about calling this 'roleResources' to be clear that this is a role 
breakdown, rather than say, a type, name, etc breakdown?
    
    If the type was `hashmap<Role, Resources>` we could just call the argument 
`resources`, but in-lieu of this, `roleResources` helps the reader more than 
`resourcesMap`. :)


- Ben Mahler


On June 22, 2015, 11:37 a.m., haosdent huang wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/35717/
> -----------------------------------------------------------
> 
> (Updated June 22, 2015, 11:37 a.m.)
> 
> 
> Review request for mesos, Adam B and Michael Park.
> 
> 
> Bugs: MESOS-692
>     https://issues.apache.org/jira/browse/MESOS-692
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Add reservations support to master's state.json
> 
> 
> Diffs
> -----
> 
>   src/common/http.hpp 6f100f74e4d3c10a087b4af11fc6864293f0f6f8 
>   src/common/http.cpp 4c8102e3cd75e9284dac3d535545370ca37f502c 
>   src/master/http.cpp b893013ddd052cb58c520ac0328f4a5f0fed862e 
>   src/tests/common/http_tests.cpp 97a0eba896aa56acc244afbff83c155024aaedbf 
> 
> Diff: https://reviews.apache.org/r/35717/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> haosdent huang
> 
>

Reply via email to