> On June 26, 2015, 6:44 p.m., Ben Mahler wrote:
> > src/common/http.cpp, line 84
> > <https://reviews.apache.org/r/35717/diff/4/?file=989671#file989671line84>
> >
> >     How about calling this 'roleResources' to be clear that this is a role 
> > breakdown, rather than say, a type, name, etc breakdown?
> >     
> >     If the type was `hashmap<Role, Resources>` we could just call the 
> > argument `resources`, but in-lieu of this, `roleResources` helps the reader 
> > more than `resourcesMap`. :)

I commented about this in the initial review as well: 
https://reviews.apache.org/r/35717/#comment141259

@hasodent's point was that the `std::string` could be any key, as opposed to 
`role`-specific. I'm fine with keeping this `role`-specific until we need to 
generalize it though.


- Michael


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/35717/#review89538
-----------------------------------------------------------


On June 22, 2015, 11:37 a.m., haosdent huang wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/35717/
> -----------------------------------------------------------
> 
> (Updated June 22, 2015, 11:37 a.m.)
> 
> 
> Review request for mesos, Adam B and Michael Park.
> 
> 
> Bugs: MESOS-692
>     https://issues.apache.org/jira/browse/MESOS-692
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Add reservations support to master's state.json
> 
> 
> Diffs
> -----
> 
>   src/common/http.hpp 6f100f74e4d3c10a087b4af11fc6864293f0f6f8 
>   src/common/http.cpp 4c8102e3cd75e9284dac3d535545370ca37f502c 
>   src/master/http.cpp b893013ddd052cb58c520ac0328f4a5f0fed862e 
>   src/tests/common/http_tests.cpp 97a0eba896aa56acc244afbff83c155024aaedbf 
> 
> Diff: https://reviews.apache.org/r/35717/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> haosdent huang
> 
>

Reply via email to