-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/36037/#review90408
-----------------------------------------------------------



src/master/http.cpp (lines 328 - 345)
<https://reviews.apache.org/r/36037/#comment143450>

    Let's move these lines into a method like:
    
    Try<Call> unmarshal(contentType, body)
    
    since essentially we are just unmarshaling the request here.



src/master/http_constants.cpp (lines 27 - 28)
<https://reviews.apache.org/r/36037/#comment143451>

    Let's just keep these 2 constants, as the rest seem too generic as per 
BenM's comments. Also , in my opinion, it would be a good idea to move these in 
src/common/http_constants.hpp/cpp . I see us using the same constants also for 
the executor HTTP API's.


Two more minor suggestions before we decide to break this into smaller chunks.

- Anand Mazumdar


On July 2, 2015, 8:16 a.m., Isabel Jimenez wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/36037/
> -----------------------------------------------------------
> 
> (Updated July 2, 2015, 8:16 a.m.)
> 
> 
> Review request for mesos, Anand Mazumdar, Benjamin Hindman, Ben Mahler, Marco 
> Massenzio, and Vinod Kone.
> 
> 
> Bugs: MESOS-2860
>     https://issues.apache.org/jira/browse/MESOS-2860
> 
> 
> Repository: mesos-incubating
> 
> 
> Description
> -------
> 
> Adding a call route with HTTP request header validations
> 
> 
> Diffs
> -----
> 
>   src/Makefile.am a064d17 
>   src/master/http.cpp 2be613b 
>   src/master/http_constants.hpp PRE-CREATION 
>   src/master/http_constants.cpp PRE-CREATION 
>   src/master/master.hpp af83d3e 
>   src/master/master.cpp a7486d8 
>   src/master/validation.hpp 469d6f5 
>   src/master/validation.cpp 9d128aa 
>   src/tests/call_tests.cpp PRE-CREATION 
>   src/tests/mesos.hpp 9157ac0 
> 
> Diff: https://reviews.apache.org/r/36037/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Isabel Jimenez
> 
>

Reply via email to