-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/39492/#review107157
-----------------------------------------------------------



include/mesos/quota/quota.proto (line 56)
<https://reviews.apache.org/r/39492/#comment166120>

    I think `guarantees` is not a good name, because quota can be more than 
just guarantee. Imagine `status.guarantees[0].limit`. How about naming it 
`infos`?



src/master/quota_handler.cpp (lines 190 - 191)
<https://reviews.apache.org/r/39492/#comment166124>

    Do you want to add a check here similar to `set()`?
    
    ```
      // Check that the request type is GET which is guaranteed by the master.
      CHECK_EQ("GET", request.method);
    ```



src/master/quota_handler.cpp (line 194)
<https://reviews.apache.org/r/39492/#comment166122>

    s/quotaInfo/quota



src/master/quota_handler.cpp (line 195)
<https://reviews.apache.org/r/39492/#comment166121>

    Am I right that there is another way to achieve the same:
    ```
    status.mutable_guarantees()->Add()->CopyFrom(quotaInfo.info);
    ```
    
    Do you know what the difference is and what approach is preferable?



src/master/quota_handler.cpp (line 198)
<https://reviews.apache.org/r/39492/#comment166123>

    Excessive empty line


- Alexander Rukletsov


On Nov. 16, 2015, 1:13 p.m., Joerg Schad wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/39492/
> -----------------------------------------------------------
> 
> (Updated Nov. 16, 2015, 1:13 p.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov, Bernd Mathiske, and Joris Van 
> Remoortere.
> 
> 
> Bugs: MESOS-3073
>     https://issues.apache.org/jira/browse/MESOS-3073
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added status handling for quota master endpoint.
> Tests are in next Review.
> 
> 
> Diffs
> -----
> 
>   include/mesos/quota/quota.proto 4e4d8ccc92e2bf9a8e5eae8488c0c952f82fdd6d 
>   src/master/master.hpp ead8520b7108a0f2c3a0bb11ae7b543897d111a2 
>   src/master/quota_handler.cpp PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/39492/diff/
> 
> 
> Testing
> -------
> 
> Test output: 
> {"quota":[{"guarantee":{"cpus":4.0,"disk":0,"mem":5.0},"role":"test"}]}
> 
> 
> Thanks,
> 
> Joerg Schad
> 
>

Reply via email to