Github user juliuszsompolski commented on a diff in the pull request:
    --- Diff: core/src/main/java/org/apache/spark/io/ 
    @@ -78,9 +79,8 @@
       // whether there is a read ahead task running,
       private boolean isReading;
    -  // If the remaining data size in the current buffer is below this 
    -  // we issue an async read from the underlying input stream.
    -  private final int readAheadThresholdInBytes;
    +  // whether there is a reader waiting for data.
    +  private AtomicBoolean isWaiting = new AtomicBoolean(false);
    --- End diff --
    I'll leave it be - should compile to basically the same, and with using 
`AtomicBoolean` the intent seems more readable to me.


To unsubscribe, e-mail:
For additional commands, e-mail:

Reply via email to