Github user BryanCutler commented on a diff in the pull request:

    https://github.com/apache/spark/pull/20556#discussion_r168263131
  
    --- Diff: dev/lint-python ---
    @@ -82,6 +87,34 @@ else
         rm "$PYCODESTYLE_REPORT_PATH"
     fi
     
    +# Check python document style, skip check if pydocstyle is not installed.
    +if hash "$PYDOCSTYLEBUILD" 2> /dev/null; then
    +    if [ $PYDOCSTYLEVERSION == "2.1.1" ]; then
    --- End diff --
    
    What happens when a new version of pydocstyle is released?  Would the same 
rules below still work so that this check could be `>= 2.1.1`?


---

---------------------------------------------------------------------
To unsubscribe, e-mail: reviews-unsubscr...@spark.apache.org
For additional commands, e-mail: reviews-h...@spark.apache.org

Reply via email to