On 12.08.2009 01:13, Thomas Martitz wrote:
If you look at the ASCII-table, the underscore (and a few more chars) is between the upper and lower case chars.
Ok, that is the point I missed. I thought it was before all the letters (upper and lower case). Everything else made perfect sense to me (converting both to upper or lower case).
I would change the name of the nat_toupper to something like "unify_case" or the like.
I would also remove the code that is now deactivated via "#if 0." Such things always make me ask whether the author wanted to just temporarily deactivate the code or ...? The similarity to the original code must not necesserily be maintained in this particular case IMO. We should make code easily readable and understandable instead.
