Björn Stenberg schrieb:
Thomas Martitz wrote:
It looks weird, indeed. But it shouldn't have been called
nat_toupper in the first place imo but something more generic
instead.
Then change it. There is no point in keeping confusing code for historical
reasons.
Frank Gevaerts schrieb:
On Wed, Aug 12, 2009 at 10:36:09AM +0200, Al Le wrote:
On 12.08.2009 01:13, Thomas Martitz wrote:
I would also remove the code that is now deactivated via "#if 0." Such
things always make me ask whether the author wanted to just temporarily
deactivate the code or ...? The similarity to the original code must not
necesserily be maintained in this particular case IMO. We should make
code easily readable and understandable instead.
I agree. We're not going to merge back from wherever this code came
from, since we seem to have pretty different requirements, and it's
pretty simple code anyway. Best clean it up.
Frank
Well, ok. I just thought it's a good idea to not change imported code
too much when not really needed.
Regards.