Hi Matt, and thanks for your response.

I have tried this.  It still produces nothing.  Here is what I added to my 

Set($MailCommand, "mbox");
Set($SendmailPath, "/usr/lib/sendmail");
Set($SendmailArguments, "-t");
Set($OwnerEmail, "m...@workplace.com"); 

I have also tried:
Set($MailCommand, "sendmailpipe");
Set($MailCommand, "smtp");
Set($MailCommand, "sendmail");
Set($MailCommand, "test");

I do a '/etc/init.d/request-tracker4 restart' after each, and even try 
rebooting.  No good.

I'm sure I'm missing something silly here... but I just don't know what it is...

Any other suggestions?

Thank you.

From: Matt Zagrabelny <mzagr...@d.umn.edu>
Sent: Friday, August 21, 2015 4:05 PM
To: Ditri, Chris
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] No outbound email after upgrade

On Fri, Aug 21, 2015 at 2:09 PM, Ditri, Chris <cdi...@experi-metal.com> wrote:

> But, it was always able to send emails with no problem through exim, and I 
> can send emails from the bash command prompt with no problem as well.

>From RT_Config.pm:

        $MailCommand defines which method RT will use to try to send mail.
        We know that 'sendmailpipe' works fairly well. If 'sendmailpipe'
        doesn't work well for you, try 'sendmail'. 'qmail' is also a
        supported value.

        For testing purposes, or to simply disable sending mail out into the
        world, you can set $MailCommand to 'mbox' which logs all mail, in
        mbox format, to files in /opt/rt4/var/ based in the process start
        time. The 'testfile' option is similar, but the files that it
        creates (under /tmp) are temporary, and removed upon process
        completion; the format is also not mbox-compatable.

Perhaps try setting MailCommand to mbox or testfile.


Reply via email to