Update: still not working. I tried setting sql-mode to an empty string,
like it would have been in 5.5, and to all the 5.7 standard ones except
strict_trans_tables. Neither helped. Updating existing tickets, and all
data retrieval, seem to work fine. It's just that priority getting a string
(that looks like a variable pointer) instead of an integer that's causing
the problem. Until I fix this, no one can make tickets, so if anyone has
any suggestions, please share them. Thanks.

On Mon, Nov 14, 2016 at 11:37 AM, Alex Hall <ah...@autodist.com> wrote:

> Hello again all,
> I just discovered I have a more serious problem than full-text indexing
> not working. I'm getting an error when anyone tries to make a ticket, and
> the ticket is never created. Here's the message:
> Nov 14 11:31:03 server24 RT: [2522] DBD::mysql::st execute failed:
> Incorrect integer value: 'ARRAY(0x18325928)' for column 'Priority' at row 1
> at /usr/share/perl5/DBIx/SearchBuilder/Handle.pm line 586.
> I have the PriorityAsString extension installed, but that's been working
> perfectly for weeks. I've also modified some files so that the user can
> select a priority on the main ticket creation page instead of going to the
> details view, but that's also been working smoothly. The only major change
> is the MySQL 5.5 upgrade to 5.7, but why that would be the cause, given the
> error message, I'm not sure. If RT were trying to insert a string like that
> before, it should have never worked. Is there anything I can do to fix
> this? I'd rather not revert to 5.5, because I still want that full-text
> indexing at some point and would rather fix this problem so I can keep
> trying to do that. Thanks!
> --
> Alex Hall
> Automatic Distributors, IT department
> ah...@autodist.com

Alex Hall
Automatic Distributors, IT department
RT 4.4 and RTIR training sessions, and a new workshop day! 
* Los Angeles - January 9-11 2017

Reply via email to