Hi all,
Ticket creation is working, now that I've finally gotten it out of strict
mode. You'd think it would check its own cnf file for errors on startup,
but nope, it doesn't notice until you try to log in using the 'mysql -u'
command. Not even an error in the log file. Anyway...

Priority is still not sticking, which doesn't surprise me. If RT is
inserting a string into an int, MySQL would put a 0 in that field. What did
surprise me is that disabling the PriorityAsString extension didn't help. I
set the priority to be 15, and when I created the cicket, it was still 0.
Yet the log shows none of the messages I've been seeing, as though it
thought it worked. Very odd stuff.

As to testing, yes, I normally do. I got to work very early today--a
Monday--with my mind set on updating MySQL and enabling full text search
before people got here and started using the system. Because of the hour,
or maybe because the tutorials I'd read made updating sound so easy, I
completely forgot to run all this on the test server first. Not a good move
on my part.

On Mon, Nov 14, 2016 at 4:24 PM, Matt Zagrabelny <mzagr...@d.umn.edu> wrote:

> Hi Alex,
> On Mon, Nov 14, 2016 at 10:37 AM, Alex Hall <ah...@autodist.com> wrote:
> > Hello again all,
> > I just discovered I have a more serious problem than full-text indexing
> not
> > working. I'm getting an error when anyone tries to make a ticket, and the
> > ticket is never created. Here's the message:
> >
> > Nov 14 11:31:03 server24 RT: [2522] DBD::mysql::st execute failed:
> Incorrect
> > integer value: 'ARRAY(0x18325928)' for column 'Priority' at row 1 at
> > /usr/share/perl5/DBIx/SearchBuilder/Handle.pm line 586.
> >
> > I have the PriorityAsString extension installed, but that's been working
> > perfectly for weeks. I've also modified some files so that the user can
> > select a priority on the main ticket creation page instead of going to
> the
> > details view, but that's also been working smoothly. The only major
> change
> > is the MySQL 5.5 upgrade to 5.7, but why that would be the cause, given
> the
> > error message, I'm not sure. If RT were trying to insert a string like
> that
> > before, it should have never worked. Is there anything I can do to fix
> this?
> > I'd rather not revert to 5.5, because I still want that full-text
> indexing
> > at some point and would rather fix this problem so I can keep trying to
> do
> > that. Thanks!
> Some thoughts...
> What do your PriorityAsString configs look like?
> Try disabling PriorityAsString.
> I know it doesn't help where you're at right now, but are you testing
> your changes in a test environment before making these changes in
> production?
> -m

Alex Hall
Automatic Distributors, IT department
RT 4.4 and RTIR training sessions, and a new workshop day! 
* Los Angeles - January 9-11 2017

Reply via email to